summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Krause2015-06-13 11:55:42 +0200
committerChristian Krause2015-06-13 11:55:42 +0200
commit343296d5b533075130a146819f6d05c597a7b919 (patch)
tree0f6ba67d7eca5b51781afe013c0bc83bbb9dddc4
downloadaur-343296d5b533075130a146819f6d05c597a7b919.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD43
-rw-r--r--irssi-libnotify-git.install34
3 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a317df192052
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = irssi-libnotify-git
+ pkgdesc = libnotify plugin for irssi
+ pkgver = r38.8f8f9e1
+ pkgrel = 1
+ url = https://code.google.com/p/irssi-libnotify/
+ install = irssi-libnotify-git.install
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = irssi
+ depends = libnotify>=0.7
+ depends = python2-gobject
+ depends = perl-html-parser
+ source = irssi-libnotify-git::git+https://code.google.com/p/irssi-libnotify/
+ source = irssi-libnotify-git.install
+ md5sums = SKIP
+ md5sums = 274448951b53b5a492a80e794e61b9fd
+
+pkgname = irssi-libnotify-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8bc872b63886
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Christian Krause ("wookietreiber") <kizkizzbangbang@googlemail.com>
+# Contributor: Daniel Wallace <daniel.wallace at gatech dot edu>
+
+_pkgname_base=irssi-libnotify
+pkgname=$_pkgname_base-git
+
+pkgver=r38.8f8f9e1
+pkgrel=1
+pkgdesc="libnotify plugin for irssi"
+arch=("any")
+url="https://code.google.com/p/irssi-libnotify/"
+license=('GPL')
+depends=('irssi' 'libnotify>=0.7' 'python2-gobject' 'perl-html-parser')
+makedepends=('git')
+
+source=("$pkgname"::'git+https://code.google.com/p/irssi-libnotify/'
+ 'irssi-libnotify-git.install')
+
+install='irssi-libnotify-git.install'
+
+md5sums=('SKIP'
+ '274448951b53b5a492a80e794e61b9fd')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+
+ sed -i 's:python:&2:' notify-listener.py
+ sed -i 's?~/bin/irssi-notifier.sh?/usr/bin/irssi-notifier?' notify.pl
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+
+ install -Dm755 irssi-notifier.sh "$pkgdir/usr/bin/irssi-notifier"
+ install -Dm755 notify-listener.py "$pkgdir/usr/bin/notify-listener"
+ install -Dm644 notify.pl "$pkgdir/usr/share/irssi/scripts/notify.pl"
+}
diff --git a/irssi-libnotify-git.install b/irssi-libnotify-git.install
new file mode 100644
index 000000000000..67f5b43c4169
--- /dev/null
+++ b/irssi-libnotify-git.install
@@ -0,0 +1,34 @@
+post_install() { cat << EOF
+
+Plugin Activation
+-----------------
+
+To enable this plugin for your local user account, link it to your
+irssi autorun scripts:
+
+ ln -s /usr/share/irssi/scripts/notify.pl ~/.irssi/scripts/autorun/
+
+Remote Access
+-------------
+
+If you are running irssi remotely, currently your remote machine account
+will need to be able to ssh to your local machine without a passphrase.
+You will need to set that up yourself, e.g. by using:
+
+ ssh-copy-id
+
+Then, to activate the remote notification in irssi, use:
+
+ /SET notify_remote <HOST>
+
+Replace <HOST> with the name or IP address of the local machine you are
+on, as it would be known to the remote machine. This is most useful if
+you are on the same local network with the other box (firewalls or other
+non-local routing will probably make it difficult to use this feature).
+
+EOF
+}
+
+post_upgrade() {
+ post_install
+}