summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12020-02-04 02:49:21 +0800
committerChocobo12020-02-04 02:50:09 +0800
commit01f2503842dc933afd606ba9bc36b26a6bc62389 (patch)
treee565f830c2151faf3e4ca8120bf492f93af272ea
parent661b3a8ef1b2fba98e955b6aafa78dd51798f636 (diff)
downloadaur-01f2503842dc933afd606ba9bc36b26a6bc62389.tar.gz
upgpkg: irtt 0.9.0-2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e581593af01d..1b386667436a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = irtt
pkgdesc = Isochronous round-trip tester
pkgver = 0.9.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/heistp/irtt
arch = i686
arch = x86_64
@@ -9,8 +9,8 @@ pkgbase = irtt
makedepends = git
makedepends = go-pie
depends = glibc
- source = https://github.com/heistp/irtt/archive/v0.9.0.tar.gz
- source = https://github.com/heistp/irtt/releases/download/v0.9.0/v0.9.0.tar.gz.asc
+ source = irtt-0.9.0.tar.gz::https://github.com/heistp/irtt/archive/v0.9.0.tar.gz
+ source = irtt-0.9.0.tar.gz.asc::https://github.com/heistp/irtt/releases/download/v0.9.0/v0.9.0.tar.gz.asc
validpgpkeys = 35C296FC733AA777B03DB9A8CAEC8F418885D165
sha256sums = f9767fa9259db1932d011ed0a9f9528c70411878668ba0db6451264557ddd800
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 744cf8899425..68d6e94242ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
pkgname=irtt
pkgver=0.9.0
-pkgrel=1
+pkgrel=2
pkgdesc="Isochronous round-trip tester"
arch=('i686' 'x86_64')
url="https://github.com/heistp/irtt"
license=('GPL3')
depends=('glibc')
makedepends=('git' 'go-pie')
-source=("https://github.com/heistp/irtt/archive/v$pkgver.tar.gz"
- "https://github.com/heistp/irtt/releases/download/v$pkgver/v$pkgver.tar.gz.asc")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/heistp/irtt/archive/v$pkgver.tar.gz"
+ "$pkgname-$pkgver.tar.gz.asc::https://github.com/heistp/irtt/releases/download/v$pkgver/v$pkgver.tar.gz.asc")
sha256sums=('f9767fa9259db1932d011ed0a9f9528c70411878668ba0db6451264557ddd800'
'SKIP')
validpgpkeys=('35C296FC733AA777B03DB9A8CAEC8F418885D165') # Pete Heist <pete@eventide.io>
@@ -31,6 +31,7 @@ build() {
GOPATH="$srcdir/gopath" \
go get \
+ -trimpath \
-ldflags "-extldflags $LDFLAGS" \
./...
}