summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12020-10-03 13:55:45 +0800
committerChocobo12020-10-03 13:58:12 +0800
commitd1aaa492269a3d892982f7de9165e8d485975e9f (patch)
treed7ec90b3041b29d98abde98dd334b188f9feba71
parent239efd6729ca6ceeb261afd4e0437b3806a8bfb2 (diff)
downloadaur-d1aaa492269a3d892982f7de9165e8d485975e9f.tar.gz
upgpkg: irtt 0.9.0-6
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 434c37ed491d..37d4d232434b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = irtt
pkgdesc = Isochronous round-trip tester
pkgver = 0.9.0
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/heistp/irtt
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 6e259c484cf0..d0606945e8fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=irtt
pkgver=0.9.0
-pkgrel=5
+pkgrel=6
pkgdesc="Isochronous round-trip tester"
arch=('i686' 'x86_64')
url="https://github.com/heistp/irtt"
@@ -16,15 +16,17 @@ sha256sums=('f9767fa9259db1932d011ed0a9f9528c70411878668ba0db6451264557ddd800'
validpgpkeys=('35C296FC733AA777B03DB9A8CAEC8F418885D165') # Pete Heist <pete@eventide.io>
+export CGO_CPPFLAGS="${CPPFLAGS}"
+export CGO_CFLAGS="${CFLAGS}"
+export CGO_CXXFLAGS="${CXXFLAGS}"
+export CGO_LDFLAGS="${LDFLAGS}"
+export GOFLAGS="-buildmode=pie -ldflags=-linkmode=external -trimpath -modcacherw" # -mod=readonly
+
build() {
cd "$pkgname-$pkgver"
go mod init "github.com/heistp/irtt"
go build \
- -buildmode=pie \
- -ldflags "-extldflags $LDFLAGS" \
- -trimpath \
- -modcacherw \
"github.com/heistp/irtt/cmd/irtt"
}
@@ -32,7 +34,6 @@ check() {
cd "$pkgname-$pkgver"
go test \
- -mod=readonly \
./...
}