summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12020-06-10 16:17:21 +0800
committerChocobo12020-06-10 16:17:21 +0800
commitf6a935b81cbd383f2fcbaaddfa40dc7dca3d9850 (patch)
tree66ae992c65cd96c0d3c08d7644fd12cce417a574
parentbdca4a69e8b8fd449c86aa6561aeee5d774951dc (diff)
downloadaur-f6a935b81cbd383f2fcbaaddfa40dc7dca3d9850.tar.gz
upgpkg: irtt 0.9.0-4
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD21
2 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf728852a8d2..5263d7e39b7a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = irtt
pkgdesc = Isochronous round-trip tester
pkgver = 0.9.0
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/heistp/irtt
arch = i686
arch = x86_64
license = GPL3
makedepends = git
- makedepends = go-pie
+ makedepends = go
depends = glibc
source = irtt-0.9.0.tar.gz::https://github.com/heistp/irtt/archive/v0.9.0.tar.gz
source = irtt-0.9.0.tar.gz.asc::https://github.com/heistp/irtt/releases/download/v0.9.0/v0.9.0.tar.gz.asc
diff --git a/PKGBUILD b/PKGBUILD
index 69b319578556..6110e1c6fe5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=irtt
pkgver=0.9.0
-pkgrel=3
+pkgrel=4
pkgdesc="Isochronous round-trip tester"
arch=('i686' 'x86_64')
url="https://github.com/heistp/irtt"
license=('GPL3')
depends=('glibc')
-makedepends=('git' 'go-pie')
+makedepends=('git' 'go')
source=("$pkgname-$pkgver.tar.gz::https://github.com/heistp/irtt/archive/v$pkgver.tar.gz"
"$pkgname-$pkgver.tar.gz.asc::https://github.com/heistp/irtt/releases/download/v$pkgver/v$pkgver.tar.gz.asc")
sha256sums=('f9767fa9259db1932d011ed0a9f9528c70411878668ba0db6451264557ddd800'
@@ -19,18 +19,21 @@ validpgpkeys=('35C296FC733AA777B03DB9A8CAEC8F418885D165') # Pete Heist <pete@ev
build() {
cd "$pkgname-$pkgver"
- GO111MODULE=on \
- go build \
- -trimpath \
- -ldflags "-extldflags $LDFLAGS" \
- "github.com/heistp/irtt/cmd/irtt"
+ go mod init "github.com/heistp/irtt"
+ go build \
+ -buildmode=pie \
+ -ldflags "-extldflags $LDFLAGS" \
+ -trimpath \
+ -modcacherw \
+ "github.com/heistp/irtt/cmd/irtt"
}
check() {
cd "$pkgname-$pkgver"
- GO111MODULE=on \
- go test "github.com/heistp/irtt/cmd/irtt"
+ go test \
+ -mod=readonly \
+ ./...
}
package() {