summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbitwave2015-06-09 14:33:44 +0200
committerbitwave2015-06-09 14:33:44 +0200
commitdc4573c14119dcff064807f69abdd760045a53a1 (patch)
treee0868dbee3d9e410fbb466ad0e13008a83d83947
downloadaur-dc4573c14119dcff064807f69abdd760045a53a1.tar.gz
Initial Import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD33
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..397649d4f1dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = isabelle
+ pkgdesc = Isabelle is a generic proof assistant. It allows mathematical formulas to be expressed in a formal language and provides tools for proving those formulas in a logical calculus.
+ pkgver = 2015
+ pkgrel = 1
+ url = http://www.cl.cam.ac.uk/research/hvg/Isabelle/
+ arch = i686
+ arch = x86_64
+ groups = science
+ license = custom:BSD
+ depends = perl
+ depends = perl-libwww
+ depends = python2
+ optdepends = texlive-core: document preparation
+ provides = isabelle
+ conflicts = isabelle
+ source = http://www.cl.cam.ac.uk/research/hvg/Isabelle/dist/Isabelle2015_linux.tar.gz
+ md5sums = da5b4ca16cd0c83418514a5ea7ebec77
+ sha256sums = c2a0dee5eb698b4a7f2fa785316e32682d67c36aabbc1f683cbca2860aa9788e
+
+pkgname = isabelle
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e6646fb6659
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: bitwave <aur [at] oomlu [dot] de>
+# Contributor: Fabian Ruch <bafain [At] gmail [dOT] com>
+pkgname=isabelle
+pkgver=2015
+pkgrel=1
+pkgdesc="Isabelle is a generic proof assistant. It allows mathematical formulas to be expressed in a formal language and provides tools for proving those formulas in a logical calculus."
+arch=('i686' 'x86_64')
+url="http://www.cl.cam.ac.uk/research/hvg/Isabelle/"
+license=('custom:BSD')
+groups=('science')
+depends=('perl' 'perl-libwww' 'python2')
+if test "$CARCH" == x86_64; then
+ depends+=('lib32-glibc' 'lib32-gcc-libs')
+fi
+optdepends=('texlive-core: document preparation')
+provides=(isabelle)
+conflicts=(isabelle)
+source=(http://www.cl.cam.ac.uk/research/hvg/Isabelle/dist/Isabelle${pkgver//_/-}_linux.tar.gz)
+md5sums=('da5b4ca16cd0c83418514a5ea7ebec77')
+sha256sums=('c2a0dee5eb698b4a7f2fa785316e32682d67c36aabbc1f683cbca2860aa9788e')
+
+build() {
+ cd "$srcdir/Isabelle${pkgver//_/-}"
+ ./bin/isabelle build Pure
+ ./bin/isabelle build HOL
+}
+
+package() {
+ cd "$srcdir/Isabelle${pkgver//_/-}"
+ mkdir -p $pkgdir/opt/isabelle
+ cp -r * $pkgdir/opt/isabelle/
+ $pkgdir/opt/isabelle/bin/isabelle install -d /opt/isabelle $pkgdir/usr/bin
+}