summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMW3602020-04-23 13:26:48 +0200
committerMW3602020-04-23 13:26:48 +0200
commit6f2409f4eb252636cd18e744ba6f2c68ccd1071c (patch)
tree48e2c086f7ad6c9559fc52e34c4f22deaa272a80
downloadaur-6f2409f4eb252636cd18e744ba6f2c68ccd1071c.tar.gz
initialize isabelle-tum package
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD39
-rw-r--r--isabelle.desktop9
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b6aeb3b75fed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = isabelle-tum
+ pkgdesc = A generic proof assistant. It allows mathematical formulas to be expressed in a formal language and provides tools for proving those formulas in a logical calculus. Release mirror: TUM.
+ pkgver = 2020
+ pkgrel = 1
+ url = https://isabelle.in.tum.de/
+ arch = i686
+ arch = x86_64
+ groups = science
+ license = custom:BSD
+ depends = perl
+ depends = perl-libwww
+ optdepends = texlive-core: document preparation
+ conflicts = isabelle
+ source = https://isabelle.in.tum.de/dist/Isabelle2020_linux.tar.gz
+ source = isabelle.desktop
+ md5sums = 7c69d3aa39116cd4a91ad1592a0431e1
+ md5sums = 63add57fc05e5334ad1582d07a0c7146
+ sha256sums = 633aff864d6647bd175cf831e7513e3fd0cd06beacbf29a5c6c66d4de1522bae
+ sha256sums = a619c0c48805f80862c4bb8f2448ce8f3d0bef7cebda7ef98a21bdd40a5652da
+
+pkgname = isabelle-tum
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea507e2d2830
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+pkgname=isabelle-tum
+pkgver=2020
+pkgrel=1
+pkgdesc="A generic proof assistant. It allows mathematical formulas to be expressed in a formal language and provides tools for proving those formulas in a logical calculus. Release mirror: TUM."
+arch=('i686' 'x86_64')
+url="https://isabelle.in.tum.de/"
+license=('custom:BSD')
+groups=('science')
+depends=('perl' 'perl-libwww')
+conflicts=('isabelle')
+if test "$CARCH" == x86_64; then
+ optdepends+=('lib32-glibc: for improved performance of Poly/ML on x86_64 machines'
+ 'lib32-gcc-libs: for improved performance of Poly/ML on x86_64 machines')
+fi
+optdepends=('texlive-core: document preparation')
+source=(https://isabelle.in.tum.de/dist/Isabelle${pkgver//_/-}_linux.tar.gz
+ isabelle.desktop)
+sha256sums=('633aff864d6647bd175cf831e7513e3fd0cd06beacbf29a5c6c66d4de1522bae'
+ 'a619c0c48805f80862c4bb8f2448ce8f3d0bef7cebda7ef98a21bdd40a5652da')
+md5sums=('7c69d3aa39116cd4a91ad1592a0431e1'
+ '63add57fc05e5334ad1582d07a0c7146')
+
+
+# required Packages are automatically build on the first run
+#
+# build() {
+# cd "$srcdir/Isabelle${pkgver//_/-}"
+# ./bin/isabelle build Pure
+# ./bin/isabelle build HOL
+# }
+
+package() {
+ install -Dm644 "isabelle.desktop" "$pkgdir/usr/share/applications/isabelle.desktop"
+
+ cd "$srcdir/Isabelle${pkgver//_/-}"
+ mkdir -p $pkgdir/opt/isabelle
+ cp -r * $pkgdir/opt/isabelle/
+ $pkgdir/opt/isabelle/bin/isabelle install -d /opt/isabelle $pkgdir/usr/bin
+}
diff --git a/isabelle.desktop b/isabelle.desktop
new file mode 100644
index 000000000000..9c6f94b1c8f6
--- /dev/null
+++ b/isabelle.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=Isabelle
+Comment=Generic proof assistant
+Exec=/usr/bin/isabelle jedit
+Icon=/opt/isabelle/lib/icons/isabelle.xpm
+Terminal=false
+Categories=Education;Science;Math;
+X-Desktop-File-Install-Version=0.22