summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Wiggins2015-11-08 21:03:26 +0000
committerAlex Wiggins2015-11-08 21:03:26 +0000
commit302062cf8616a9894cc0c127b3f3658b195dd29f (patch)
treeca85f1911b7e69ae5a8e2b16e50ba84678ad3c6c
parent1e36c89e021f94881ef38a36dca1929664a35551 (diff)
downloadaur-302062cf8616a9894cc0c127b3f3658b195dd29f.tar.gz
Update for new bundle format (1.0.0), version 1.36.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD26
2 files changed, 20 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36a3fe335d2d..f9874ed4674e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = iscan-plugin-network
pkgdesc = Plugin for using Epson scanners with ISCAN over network
- pkgver = 1.1.1
- pkgrel = 10
+ pkgver = 1.36.0
+ pkgrel = 11
url = http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX
install = iscan-plugin-network.install
arch = i686
arch = x86_64
license = custom:AVASYSPL
depends = iscan
- source = iscan-network-nt.deb::https://download3.ebz.epson.net/dsc/f/03/00/03/61/60/036fa32e8febc77061170283f84b6b1632949b23/iscan-network-nt_1.1.1-1_i386.deb
- md5sums = 08b6cd88050151892bc582182cc8a2c0
+ source = iscan-bundle.deb.tar.gz::https://download2.ebz.epson.net/iscan/general/deb/x86/iscan-bundle_1.0.0.x86.deb.tar.gz
+ sha512sums = d91a064342640582a71c664441e944812bc2fd18bd8f00010838adac7ad0581efcf8c9224c48a136ae0aec7f26b6df8071da7c2e10110eafe91c1dbd7f9865ad
pkgname = iscan-plugin-network
diff --git a/PKGBUILD b/PKGBUILD
index cf5c72bac4a5..f864c4933cf1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,10 +5,12 @@
# Contributor: Tom Kuther <gimpel@sonnenkinder.org>
pkgname=iscan-plugin-network
-_pkgintname=iscan-network-nt
-pkgver=1.1.1
-_pkgver=1.1.1-1 # workaround for hyphen in package version
-pkgrel=10
+_pkgintname=iscan-data
+_pkgdlname=iscan-bundle
+pkgver=1.36.0
+_pkgver=1.36.0-1 # workaround for hyphen in version
+_pkgdlver=1.0.0 # download bundle version
+pkgrel=11
pkgdesc="Plugin for using Epson scanners with ISCAN over network"
arch=('i686' 'x86_64')
url="http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
@@ -16,21 +18,25 @@ license=('custom:AVASYSPL')
depends=(iscan)
install=iscan-plugin-network.install
if [[ ${CARCH} = 'x86_64' ]]; then
- md5sums=('b9fedf56f04b375df85c7d73d43a922d')
- source=("iscan-network-nt.deb::https://download3.ebz.epson.net/dsc/f/03/00/03/61/60/41e00501e67a849926adf271afdb4eb258d0b6b8/${_pkgintname}_${_pkgver}_amd64.deb")
+ _pkgarch='x64'
+ sha512sums=('081ea48a83f955abd8f8d081f322e87ca02c91d371d6a7ed2d7cc4075c590c162a4ee9cd196cf5a53e6ce26fe29e34ef5a42400c06d336d2b8ccd33a6853575a')
+ source=("iscan-bundle.deb.tar.gz::https://download2.ebz.epson.net/iscan/general/deb/${_pkgarch}/${_pkgdlname}-${_pkgdlver}.${_pkgarch}.deb.tar.gz")
else
- md5sums=('08b6cd88050151892bc582182cc8a2c0')
- source=("iscan-network-nt.deb::https://download3.ebz.epson.net/dsc/f/03/00/03/61/60/036fa32e8febc77061170283f84b6b1632949b23/${_pkgintname}_${_pkgver}_i386.deb")
+ _pkgarch='x86'
+ sha512sums=('d91a064342640582a71c664441e944812bc2fd18bd8f00010838adac7ad0581efcf8c9224c48a136ae0aec7f26b6df8071da7c2e10110eafe91c1dbd7f9865ad')
+ source=("iscan-bundle.deb.tar.gz::https://download2.ebz.epson.net/iscan/general/deb/${_pkgarch}/${_pkgdlname}_${_pkgdlver}.${_pkgarch}.deb.tar.gz")
fi
-
build() {
cd $srcdir
+cd ${_pkgdlname}-${_pkgdlver}.${_pkgarch}.deb/data
+bsdtar -xf ${_pkgintname}_${_pkgver}_all.deb
bsdtar -xf data.tar.gz
+cp -R usr $srcdir
}
package() {
cd $srcdir
cp -R usr $pkgdir
-install -Dm644 usr/share/doc/${_pkgintname}/AVASYSPL.en.txt $pkgdir/usr/share/licenses/${pkgname}/AVASYSPL
+install -Dm644 usr/share/doc/${_pkgintname}/copyright $pkgdir/usr/share/licenses/${pkgname}/AVASYSPL
} \ No newline at end of file