summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2020-01-24 17:43:22 +0100
committerMuflone2020-01-24 17:43:22 +0100
commit48cc7add7d7379642fe01d70af12df132a008095 (patch)
tree6c7466289cd47605ebf5de2e9ccbdae4e1991b6e
parentc090b8ef7d204791d7789d443c126161ce2fb500 (diff)
downloadaur-48cc7add7d7379642fe01d70af12df132a008095.tar.gz
Updated package iscan-plugin-perfection-v370 2.30.4-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD50
2 files changed, 25 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94617a1affd7..8146c86faeba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,15 @@
-# Generated by mksrcinfo v8
-# Wed Nov 1 18:39:10 UTC 2017
pkgbase = iscan-plugin-perfection-v370
pkgdesc = EPSON Image Scan! plugin for Epson scanners (GT-F740, GT-S640, Perfection V37, Perfection V370)
- pkgver = 1.0.1
- pkgrel = 2
+ pkgver = 2.30.4
+ pkgrel = 1
url = http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX
install = iscan-plugin-perfection-v370.install
- arch = i686
arch = x86_64
- license = custom:AVASYSPL
+ license = custom:EPSON EULA
depends = iscan
depends = iscan-data
- source_i686 = https://download2.ebz.epson.net/iscan/plugin/perfection-v370/deb/x86/iscan-perfection-v370-bundle-1.0.1.x86.deb.tar.gz
- sha256sums_i686 = f63d65d7d180bc445617ecd5579d55fd9f614291cac5f13548d3cec86384a064
- source_x86_64 = https://download2.ebz.epson.net/iscan/plugin/perfection-v370/deb/x64/iscan-perfection-v370-bundle-1.0.1.x64.deb.tar.gz
- sha256sums_x86_64 = 3ecead560f50d991f3987a9a845393e9690c03d268ef87ea47a4f2a12cb23891
+ source = https://download2.ebz.epson.net/iscan/plugin/perfection-v370/deb/x64/iscan-perfection-v370-bundle-2.30.4.x64.deb.tar.gz
+ sha256sums = 08026cedf7b13895526b5b6267e98f1ab2c5ed9eb417c565ef37cfd4787b7b65
pkgname = iscan-plugin-perfection-v370
diff --git a/PKGBUILD b/PKGBUILD
index f0f1b8d50aa3..f4e4cb2d5438 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,41 +2,27 @@
# Contributor: Alistair Grant <akgrant0710 at gmail dot com>
pkgname=iscan-plugin-perfection-v370
-pkgver=1.0.1
-pkgrel=2
+pkgver=2.30.4
+pkgrel=1
pkgdesc="EPSON Image Scan! plugin for Epson scanners (GT-F740, GT-S640, Perfection V37, Perfection V370)"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
-license=('custom:AVASYSPL')
+license=('custom:EPSON EULA')
depends=('iscan' 'iscan-data')
-_plugin=${pkgname/iscan-plugin-/}
-_iscan_ver=1.0.1
-_plugin_rel=2
-_file_ver=1.0.0
-source_i686=("https://download2.ebz.epson.net/iscan/plugin/${_plugin}/deb/x86/iscan-${_plugin}-bundle-${_iscan_ver}.x86.deb.tar.gz")
-source_x86_64=("https://download2.ebz.epson.net/iscan/plugin/${_plugin}/deb/x64/iscan-${_plugin}-bundle-${_iscan_ver}.x64.deb.tar.gz")
-sha256sums_i686=('f63d65d7d180bc445617ecd5579d55fd9f614291cac5f13548d3cec86384a064')
-sha256sums_x86_64=('3ecead560f50d991f3987a9a845393e9690c03d268ef87ea47a4f2a12cb23891')
+source=("https://download2.ebz.epson.net/iscan/plugin/perfection-v370/deb/x64/iscan-perfection-v370-bundle-${pkgver}.x64.deb.tar.gz")
+sha256sums=('08026cedf7b13895526b5b6267e98f1ab2c5ed9eb417c565ef37cfd4787b7b65')
install="${pkgname}.install"
-if [ "$CARCH" = 'x86_64' ]
-then
- _filearch=x64
- _debarch=amd64
-else
- _filearch=x86
- _debarch=i386
-fi
-
-build() {
- cd "iscan-${_plugin}-bundle-${_iscan_ver}.${_filearch}.deb/plugins"
- bsdtar -xf "${pkgname}_${_file_ver}-${_plugin_rel}_${_debarch}.deb"
+prepare() {
+ cd "iscan-perfection-v370-bundle-${pkgver}.x64.deb/plugins"
+ bsdtar -xf "iscan-plugin-perfection-v370_1.0.1-1_amd64.deb"
bsdtar -xf data.tar.gz
- gzip -fkd "usr/share/doc/${pkgname}/NEWS.gz"
+ gzip -fkd "usr/share/doc/iscan-plugin-perfection-v370/NEWS.gz"
+ gzip -fkd "usr/share/doc/iscan-plugin-perfection-v370/COPYING.EPSON.en.txt.gz"
}
package() {
- cd "iscan-${_plugin}-bundle-${_iscan_ver}.${_filearch}.deb/plugins/usr"
+ cd "iscan-perfection-v370-bundle-${pkgver}.x64.deb/plugins/usr"
# Install plugins
install -m 755 -d "${pkgdir}/usr/lib/iscan"
install -m 644 -t "${pkgdir}/usr/lib/iscan" "lib/iscan/lib${pkgname}.so.0.0.0"
@@ -47,12 +33,16 @@ package() {
install -m 644 -t "${pkgdir}/usr/share/iscan" "share/iscan/esfwdd.bin"
# Install shared data
install -m 755 -d "${pkgdir}/usr/share/iscan-data/device"
- install -m 644 -t "${pkgdir}/usr/share/iscan-data/device" "share/iscan-data/device/47542d46373430.xml"
- install -m 644 -t "${pkgdir}/usr/share/iscan-data/device" "share/iscan-data/device/47542d53363430.xml"
+ install -m 644 -t "${pkgdir}/usr/share/iscan-data/device" \
+ "share/iscan-data/device/47542d46373430.xml" \
+ "share/iscan-data/device/47542d53363430.xml"
# Install documentation
install -m 755 -d "${pkgdir}/usr/share/doc/${pkgname}"
- install -m 644 -t "${pkgdir}/usr/share/doc/${pkgname}" "share/doc/${pkgname}/NEWS"
+ install -m 644 -t "${pkgdir}/usr/share/doc/${pkgname}" \
+ "share/doc/${pkgname}/NEWS"
# Install licenses
install -m 755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
- install -m 644 "share/doc/${pkgname}/AVASYSPL.en.txt" "${pkgdir}/usr/share/licenses/${pkgname}/AVASYSPL"
+ install -m 644 -t "${pkgdir}/usr/share/licenses/${pkgname}" \
+ "share/doc/iscan-plugin-perfection-v370/COPYING.EPSON.en.txt" \
+ "share/doc/iscan-plugin-perfection-v370/copyright"
}