summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkewl fft2019-09-07 19:21:26 +0100
committerkewl fft2019-09-07 19:21:26 +0100
commit0c2b6fbf3c35e63ed6764969c43ec2229cabfff7 (patch)
treec7b8fdbbbdddbb4fc36aa67c1a439b6a5804c2d0
parentdccd8eb5de87ab177b470e159b586f007d71d3b1 (diff)
downloadaur-0c2b6fbf3c35e63ed6764969c43ec2229cabfff7.tar.gz
Update to version 1.0.0-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD52
2 files changed, 31 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df8a25066bb8..6d17f9b27793 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
pkgbase = iscan-plugin-v330
- pkgdesc = iscan plugin for Epson Perfection Photo V330 scanners.
- pkgver = 0.2.0
- pkgrel = 7
- url = http://www.epson.com
+ pkgdesc = EPSON Image Scan! plugin for Epson scanners GT-F730, GT-S630, Perfection V33, Perfection V330 Photo
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://support.epson.net/linux/en/iscan.php?model=perfection-v330
install = iscan-plugin-v330.install
- arch = i686
arch = x86_64
license = custom
depends = iscan
- source_i686 = https://download2.ebz.epson.net/iscan/plugin/perfection-v330/rpm/x86/iscan-perfection-v330-bundle-1.0.1.x86.rpm.tar.gz
- sha256sums_i686 = 29e71557d7cd4b64bac8088c3f0f53459c5a5b72a92496ced98ea624bdac72c2
- source_x86_64 = https://download2.ebz.epson.net/iscan/plugin/perfection-v330/rpm/x64/iscan-perfection-v330-bundle-1.0.1.x64.rpm.tar.gz
- sha256sums_x86_64 = f6fa455f04cdfbc3d38526573260746e9546830de93ba182d0365f557d2f7df9
+ source = https://download2.ebz.epson.net/iscan/plugin/perfection-v330/rpm/x64/iscan-perfection-v330-bundle-2.30.4.x64.rpm.tar.gz
+ sha256sums = 38082e6c080fbbfb96fa005bd8e42b36728ad6ebeff5084b677b3ee6ea2b389a
pkgname = iscan-plugin-v330
diff --git a/PKGBUILD b/PKGBUILD
index ef97fbea32a6..ea2759caa7a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,35 @@
+# Maintainer: Kewl <xrjy@nygb.rh.bet(rot13)>
# Maintainer: Facundo Tuesca <facutuesca AT gmail DOT com>
pkgname=iscan-plugin-v330
-pkgver=0.2.0
-pkgrel=7
-pkgdesc="iscan plugin for Epson Perfection Photo V330 scanners."
-arch=('i686' 'x86_64')
-url="http://www.epson.com"
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="EPSON Image Scan! plugin for Epson scanners GT-F730, GT-S630, Perfection V33, Perfection V330 Photo"
+_plugin="perfection-v330"
+_iscan_ver=2.30.4
+arch=('x86_64')
+url="http://support.epson.net/linux/en/iscan.php?model=perfection-v330"
license=('custom')
depends=('iscan')
-install=iscan-plugin-v330.install
-source_x86_64=(https://download2.ebz.epson.net/iscan/plugin/perfection-v330/rpm/x64/iscan-perfection-v330-bundle-1.0.1.x64.rpm.tar.gz)
-source_i686=(https://download2.ebz.epson.net/iscan/plugin/perfection-v330/rpm/x86/iscan-perfection-v330-bundle-1.0.1.x86.rpm.tar.gz)
-sha256sums_i686=('29e71557d7cd4b64bac8088c3f0f53459c5a5b72a92496ced98ea624bdac72c2')
-sha256sums_x86_64=('f6fa455f04cdfbc3d38526573260746e9546830de93ba182d0365f557d2f7df9')
+install="${pkgname}.install"
+source=("https://download2.ebz.epson.net/iscan/plugin/perfection-v330/rpm/x64/iscan-${_plugin}-bundle-${_iscan_ver}.x64.rpm.tar.gz")
+sha256sums=('38082e6c080fbbfb96fa005bd8e42b36728ad6ebeff5084b677b3ee6ea2b389a')
-if [ "$CARCH" = "i686" ] ; then
- ARCH=i386
-elif [ "$CARCH" = "x86_64" ] ; then
- ARCH=x86_64
-fi
-
-build() {
- mv "$srcdir/iscan-perfection-v330-bundle-1.0.1.x64.rpm/plugins/esci-interpreter-perfection-v330-${pkgver}-1.$ARCH.rpm" "$srcdir/"
- bsdtar -x -f "esci-interpreter-perfection-v330-${pkgver}-1.$ARCH.rpm"
-
- if [ "$CARCH" = "x86_64" ] ; then
- mv usr/lib64 usr/lib
- fi
+prepare() {
+ cd "iscan-${_plugin}-bundle-${_iscan_ver}.x64.rpm/plugins"
+ bsdtar -xf "esci-interpreter-${_plugin}-${pkgver}-1.${CARCH}.rpm"
}
package() {
- mv usr "$pkgdir"
- mkdir -p $pkgdir/usr/share/licenses/$pkgname
- mv $pkgdir/usr/share/doc/esci-interpreter-perfection-v330-${pkgver}/AVASYSPL.en.txt $pkgdir/usr/share/licenses/$pkgname
- rm -rf $pkgdir/usr/share/doc
+ cd "iscan-${_plugin}-bundle-${_iscan_ver}.x64.rpm/plugins/usr"
+ # install plugin
+ install -Dm 755 -t "${pkgdir}/usr/lib/esci" "lib64/esci/libesci-interpreter-${_plugin}.so.0.0.0"
+ ln -s "libesci-interpreter-${_plugin}.so.0.0.0" "${pkgdir}/usr/lib/esci/libesci-interpreter-${_plugin}.so"
+ ln -s "libesci-interpreter-${_plugin}.so.0.0.0" "${pkgdir}/usr/lib/esci/libesci-interpreter-${_plugin}.so.0"
+ # install firmware
+ install -Dm 644 -t "${pkgdir}/usr/share/esci" "share/esci/esfwad.bin"
+ # install shared data
+ install -Dm 644 -t "${pkgdir}/usr/share/iscan-data/device" share/iscan-data/device/{47542d46373330,47542d53363330}.xml
+ # install license
+ install -Dm 644 "share/doc/esci-interpreter-${_plugin}-${pkgver}/COPYING.EPSON.en.txt" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING.EPSON"
}