summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian2022-12-24 14:40:38 +0100
committerJulian2022-12-24 14:40:38 +0100
commit45f7cd3695ea2cbc741c41275ba674b5c2c0c01f (patch)
treecbb824cb99c64f58d1baf7bb5292a67a7f954e99
parent669049943751892736a86cad8e588ef5e7d3dfca (diff)
downloadaur-45f7cd3695ea2cbc741c41275ba674b5c2c0c01f.tar.gz
Update package to use latest official source code, and to actually work
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD43
-rw-r--r--isight-firmware-tools.install17
3 files changed, 32 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a8b99f1f6a2c..32b43ba038ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,14 @@
-# Generated by mksrcinfo v8
-# Sun Feb 28 17:54:34 UTC 2016
pkgbase = isight-firmware-tools
pkgdesc = Tools to manipulate firmware for Built-in iSight found on Apple machines
pkgver = 1.6
- pkgrel = 2
- url = https://launchpad.net/isight-firmware-tools
- install = isight-firmware-tools.install
- arch = i686
+ pkgrel = 1
+ url = https://gitlab.com/bersace/isight-firmware-tools
arch = x86_64
license = GPL2
makedepends = intltool
makedepends = gcc
depends = libusb-compat
- source = http://launchpad.net/isight-firmware-tools/main/1.6/+download/isight-firmware-tools-1.6.tar.gz
- sha256sums = 3181973db8a1cadd68785cd81959c8e1e9dc8110342ec1639a50db53d82a367e
+ source = git+https://gitlab.com/bersace/isight-firmware-tools
+ sha256sums = SKIP
pkgname = isight-firmware-tools
-
diff --git a/PKGBUILD b/PKGBUILD
index b60dd8bfc3f4..d63813799a51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,39 @@
-# Maintainer: yaroslav <proninyaroslav@mail.ru>
-# Contributor: Daniel Plaza <daniel.plaza.espi@gmail.com>
+# Maintainer: Julian <juliannfairfax@protonmail.com>
pkgname=isight-firmware-tools
pkgver=1.6
-pkgrel=2
+pkgrel=1
pkgdesc="Tools to manipulate firmware for Built-in iSight found on Apple machines"
-arch=('i686' 'x86_64')
-url="https://launchpad.net/isight-firmware-tools"
-license=('GPL2')
-source=("http://launchpad.net/isight-firmware-tools/main/1.6/+download/isight-firmware-tools-${pkgver}.tar.gz")
-sha256sums=('3181973db8a1cadd68785cd81959c8e1e9dc8110342ec1639a50db53d82a367e')
-depends=('libusb-compat')
-makedepends=('intltool' 'gcc')
-install=isight-firmware-tools.install
+arch=("x86_64")
+url="https://gitlab.com/bersace/isight-firmware-tools"
+license=("GPL2")
+source=("git+https://gitlab.com/bersace/isight-firmware-tools")
+sha256sums=("SKIP")
+depends=("libusb-compat")
+makedepends=("intltool" "gcc")
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd "${srcdir}"/"$pkgname"
+
+ sed -i 's/ doc//' Makefile.am
+
+ sed -i 's/fprintf(stderr, g_option_context_get_help(context,/fprintf(stderr, "%s", g_option_context_get_help(context,/' src/export.c
+
+ sed -i 's/fprintf(stderr, g_option_context_get_help(context,/fprintf(stderr, "%s", g_option_context_get_help(context,/' src/extract.c
+
+ sed -i 's/fprintf(stderr, g_option_context_get_help(context,/fprintf(stderr, "%s", g_option_context_get_help(context,/' src/udev.c
+
+ autoreconf --install
+
./configure --prefix=/usr --sysconfdir=/etc
+
make
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
- make DESTDIR=${pkgdir} install
-}
+ cd "${srcdir}"/"$pkgname"
+
+ make DESTDIR="${pkgdir}" install
+
+ sed -i 's|/lib/firmware/isight.fw|/usr/lib/firmware/isight.fw|' "${pkgdir}"/etc/udev/rules.d/isight.rules
+} \ No newline at end of file
diff --git a/isight-firmware-tools.install b/isight-firmware-tools.install
deleted file mode 100644
index 9e2d82933767..000000000000
--- a/isight-firmware-tools.install
+++ /dev/null
@@ -1,17 +0,0 @@
-infodir=usr/share/info
-
-post_install() {
- [ -x usr/bin/install-info ] || return 0
- install-info ${infodir}/ift-export.info.gz ${infodir}/dir 2> /dev/null
- install-info ${infodir}/ift-extract.info.gz ${infodir}/dir 2> /dev/null
-}
-
-post_upgrade() {
- post_install $1
-}
-
-pre_remove() {
- [ -x usr/bin/install-info ] || return 0
- install-info --delete ${infodir}/ift-export.info.gz ${infodir}/dir 2> /dev/null
- install-info --delete ${infodir}/ift-extract.info.gz ${infodi}r/dir 2> /dev/null
-}