summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLehrgangsserver2024-03-07 08:58:13 +0100
committerLehrgangsserver2024-03-07 08:58:23 +0100
commit4e941736b95d505572be012cfa4309b2e7efad12 (patch)
treef147a8a06a64d9b7716b3d7057dab6fe29b6e832
parent0bdf4be659d5973e94f430fce6c1f5c105f3039c (diff)
downloadaur-4e941736b95d505572be012cfa4309b2e7efad12.tar.gz
update for isolate 2.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
-rw-r--r--servicefile-path.patch11
3 files changed, 30 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c42847fd1c2..9ad91f02df41 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,23 @@
-# Generated by mksrcinfo v8
-# Sat Aug 5 15:35:49 UTC 2017
pkgbase = isolate-git
pkgdesc = Sandbox for securely executing untrusted programs
- pkgver = r106.f8acf05
+ pkgver = r236.303b958
pkgrel = 1
url = https://github.com/ioi/isolate
install = isolate-git.install
arch = i686
arch = x86_64
- license = GPL2
+ license = GPL-2.0-or-later
makedepends = git
makedepends = gcc
makedepends = asciidoc
+ depends = systemd-libs
depends = libcap
+ depends = glibc
provides = isolate
conflicts = isolate
- source = git://github.com/ioi/isolate.git
+ source = git+https://github.com/ioi/isolate.git
+ source = servicefile-path.patch
sha512sums = SKIP
+ sha512sums = 125b4d1dac18e17d84e9fdede28a450f21b96bb9c4a0ca4c07ff1d49862c04a5579735edc2e5f3309ddc0a7076c7ffe9af772aa454e9f5a3562efa7e8ecec5cd
pkgname = isolate-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 4ba2f9e8385f..bdcd93e698bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,24 @@
+# Maintainer: German IOI Coaches <coaches@informatik-olympiade.de>
# Maintainer: Alexandre Macabies <web+oss@zopieux.com>
# Maintainer: Antoine Pietri <antoine.pietri@lrde.epita.fr>
# Maintainer: William Di Luigi <williamdiluigi@gmail.com>
pkgname=isolate-git
-pkgver=r106.f8acf05
+pkgver=r236.303b958
pkgrel=1
pkgdesc="Sandbox for securely executing untrusted programs"
arch=('i686' 'x86_64')
url="https://github.com/ioi/isolate"
-license=('GPL2')
-depends=('libcap')
+license=('GPL-2.0-or-later')
+depends=('systemd-libs' 'libcap' 'glibc')
makedepends=('git' 'gcc' 'asciidoc')
provides=('isolate')
conflicts=('isolate')
install=$pkgname.install
-source=('git://github.com/ioi/isolate.git')
-sha512sums=('SKIP')
+source=('git+https://github.com/ioi/isolate.git' 'servicefile-path.patch')
+sha512sums=('SKIP'
+ '125b4d1dac18e17d84e9fdede28a450f21b96bb9c4a0ca4c07ff1d49862c04a5579735edc2e5f3309ddc0a7076c7ffe9af772aa454e9f5a3562efa7e8ecec5cd')
pkgver() {
cd isolate
@@ -30,12 +32,14 @@ build() {
package() {
cd isolate
- make PREFIX="$pkgdir/usr" VARPREFIX="$pkgdir/var" CONFIGDIR="$pkgdir/etc" install install-doc
+ make PREFIX="$pkgdir/usr" VARPREFIX="$pkgdir/var" CONFIGDIR="$pkgdir/etc" SBINDIR="$pkgdir/usr/bin" install install-doc
+ patch systemd/isolate.service < ../servicefile-path.patch
+ install -D -t "$pkgdir/usr/lib/systemd/system/" systemd/isolate.service systemd/isolate.slice
# Patch the configuration file so that it uses a standard directory
- sed -i "s|/var/local/lib/isolate|/var/lib/isolate|" $pkgdir/etc/isolate
+ sed -i "s|/var/local/lib/isolate|/var/lib/isolate|" "$pkgdir/etc/isolate"
# The isolate binary has the setuid bit set (to run as root without sudo)
# however we should let only the owner and the group be able to run it:
- chmod o-x $pkgdir/usr/bin/isolate
+ chmod o-x "$pkgdir/usr/bin/isolate"
}
diff --git a/servicefile-path.patch b/servicefile-path.patch
new file mode 100644
index 000000000000..ee82a132222d
--- /dev/null
+++ b/servicefile-path.patch
@@ -0,0 +1,11 @@
+--- /usr/lib/systemd/system/isolate.service 2024-02-29 23:50:10.000000000 +0100
++++ systemd/isolate.service 2024-03-01 00:21:28.680577647 +0100
+@@ -3,7 +3,7 @@
+
+ [Service]
+ Type=notify
+-ExecStart=/usr/local/sbin/isolate-cg-keeper
++ExecStart=/usr/bin/isolate-cg-keeper
+ Slice=isolate.slice
+ Delegate=true
+