summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoine Pietri2015-07-28 20:19:21 +0200
committerAntoine Pietri2015-07-28 20:19:21 +0200
commit5809edb54d40f64549a17a491855d17cb2c64c4b (patch)
treeee0a576cafc19d0c62cf39b89da4bacf93f80055
downloadaur-5809edb54d40f64549a17a491855d17cb2c64c4b.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c921859b9a35
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = isolate-git
+ pkgdesc = Isolate is a sandbox built to safely run untrusted executables.
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/ioi/isolate
+ arch = i686
+ arch = x86_64
+ license = AGPL3
+ makedepends = asciidoc
+ provides = isolate
+ source = git+https://github.com/ioi/isolate
+ sha512sums = SKIP
+
+pkgname = isolate-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..61adc0481ac3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Antoine Pietri <antoine.pietri@lrde.epita.fr>
+
+pkgname=isolate-git
+pkgrel=1
+pkgver=1
+pkgdesc="Isolate is a sandbox built to safely run untrusted executables."
+arch=('i686' 'x86_64')
+url="https://github.com/ioi/isolate"
+license=('AGPL3')
+provides=('isolate')
+depends=()
+makedepends=('asciidoc')
+source=("git+https://github.com/ioi/isolate")
+sha512sums=(SKIP)
+
+build() {
+ cd isolate
+ make isolate isolate.1
+}
+
+package() {
+ cd isolate
+ make PREFIX="$pkgdir/usr" install install-doc
+}