summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Scatton2021-05-28 03:46:52 +0200
committerSimon Scatton2021-05-28 03:46:52 +0200
commit0f6cea9ac8f357aadbcc1754274e3fc4720164c4 (patch)
treebc6d07714dd829438f2d59965e42114a19b76321
downloadaur-0f6cea9ac8f357aadbcc1754274e3fc4720164c4.tar.gz
Initial commit of version 1.8.2 of isolate-lib
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aae55ec603d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = isolate-lib
+ pkgdesc = Dynamic library based on the isolate program for the IOI
+ pkgver = 1.8.2
+ pkgrel = 1
+ url = https://github.com/moulinex-app/isolate
+ arch = any
+ license = GPL2
+ makedepends = git
+ makedepends = gcc
+ makedepends = libcap
+ provides = isolate-lib
+ conflicts = isolate
+ conflicts = isolate-git
+ source = https://github.com/moulinex-app/isolate/releases/download/v1.8.2/isolate-lib-v1.8.2.tar.gz
+ sha512sums = a25aef5b4161b26fd92ff3ca5ba3a40039a60da43fa83338a95382eafb7bb79d19474a958eba1b881e352d3e3fa8c91e92eb4328917389c21e11f27790c01473
+
+pkgname = isolate-lib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ce81a1373496
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Simon Scatton <simon.scatton@outlook.fr>
+
+pkgname=isolate-lib
+pkgver=1.8.2
+pkgrel=1
+pkgdesc="Dynamic library based on the isolate program for the IOI"
+arch=('any')
+url="https://github.com/moulinex-app/isolate"
+license=('GPL2')
+depends=()
+makedepends=('git' 'gcc' 'libcap')
+provides=('isolate-lib')
+conflicts=('isolate' 'isolate-git')
+source=("https://github.com/moulinex-app/isolate/releases/download/v$pkgver/$pkgname-v$pkgver.tar.gz")
+sha512sums=("a25aef5b4161b26fd92ff3ca5ba3a40039a60da43fa83338a95382eafb7bb79d19474a958eba1b881e352d3e3fa8c91e92eb4328917389c21e11f27790c01473")
+
+build() {
+ cd $pkgname-v$pkgver
+ ./configure --prefix="/usr"
+}
+
+package() {
+ cd $pkgname-v$pkgver
+ make DESTDIR="$pkgdir" install
+ mkdir $pkgdir/usr/lib/pkgconfig
+ cp isolate.pc $pkgdir/usr/lib/pkgconfig/isolate.pc
+}