summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShuyuan Liu2022-03-05 16:09:51 +0000
committerShuyuan Liu2022-03-05 16:09:51 +0000
commite11ffbe242562df5fe92300b9ce1ef2518dfee5c (patch)
treee140e0125e767c48e420d9c631dee93e0ea13a1d
downloadaur-e11ffbe242562df5fe92300b9ce1ef2518dfee5c.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
-rw-r--r--issie.desktop10
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cba32e591e32
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = issie
+ pkgdesc = Digital electronics schematic editor and simulator
+ pkgver = 2.4.5
+ pkgrel = 1
+ url = https://github.com/tomcl/ISSIE
+ arch = x86_64
+ arch = arm64
+ license = GPL3
+ makedepends = nodejs-lts-fermium
+ makedepends = npm
+ makedepends = dotnet-sdk
+ depends = hicolor-icon-theme
+ depends = zlib
+ source = issie-2.4.5.tar.gz::https://github.com/tomcl/issie/archive/refs/tags/v2.4.5.tar.gz
+ source = issie.desktop
+ sha256sums = ef90bdacd653dc0cc5e0e28b5789dce2bb08af943b668ab2d6304b2209f1a23c
+ sha256sums = 047d4635c7ada3742f76cae84b4a85892c39005c74e309ceebc0e80c325b3d3b
+
+pkgname = issie
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d26c590be8d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Shuyuan Liu <liu_shuyuan@qq.com>
+
+pkgname=issie
+pkgver=2.4.5
+pkgrel=1
+pkgdesc='Digital electronics schematic editor and simulator'
+arch=('x86_64' 'arm64')
+url='https://github.com/tomcl/ISSIE'
+license=('GPL3')
+
+depends=('hicolor-icon-theme' 'zlib')
+makedepends=('nodejs-lts-fermium' 'npm' 'dotnet-sdk')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/tomcl/issie/archive/refs/tags/v$pkgver.tar.gz"
+ "issie.desktop")
+sha256sums=('ef90bdacd653dc0cc5e0e28b5789dce2bb08af943b668ab2d6304b2209f1a23c'
+ '047d4635c7ada3742f76cae84b4a85892c39005c74e309ceebc0e80c325b3d3b')
+
+build() {
+ cd "$pkgname-$pkgver"
+ dotnet tool restore
+ dotnet paket install
+ npm update
+ npm run dist
+}
+
+package() {
+ install -D -m 644 issie.desktop "$pkgdir"/usr/share/applications/issie.desktop
+ install -D -m 755 "$pkgname-$pkgver"/dist/issie-$pkgver.AppImage "$pkgdir"/opt/appimages/issie.AppImage
+ install -D -m 644 "$pkgname-$pkgver"/build/icon.png "$pkgdir"/usr/share/icons/hicolor/512x512/apps/issie.png
+}
+
diff --git a/issie.desktop b/issie.desktop
new file mode 100644
index 000000000000..780e0729c6af
--- /dev/null
+++ b/issie.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=ISSIE
+Type=Application
+GenericName=Digital Electronics Simulator
+Comment=Interactive Schematic Simulator and Integrated Editor
+Icon=issie
+Exec=/opt/appimages/issie.AppImage
+Terminal=false
+Categories=Development;Education;Simulation;Electronics;
+