summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Cai2019-02-05 21:14:07 +0800
committerPeter Cai2019-02-05 21:14:07 +0800
commit5718a33c4cf994b8a0345cbabec5650b9574a918 (patch)
tree39998d9c0888c39698fb4547c669f2aa253692ee
parent2c75c0a9f1cc5d0ed25ddf4364b6129664ef0499 (diff)
downloadaur-5718a33c4cf994b8a0345cbabec5650b9574a918.tar.gz
update to 0.12.2
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD18
3 files changed, 23 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28dcc6aadf17..4111ecb75f26 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,30 @@
pkgbase = isso
pkgdesc = A commenting python server similar to Disqus
- pkgver = 0.10.5
- pkgrel = 3
+ pkgver = 0.12.2
+ pkgrel = 1
url = http://posativ.org/isso/
install = isso.install
arch = any
license = MIT
makedepends = git
makedepends = python
+ makedepends = python-sphinx
+ depends = python-bleach
+ depends = python-jinja
depends = python-werkzeug
depends = python-html5lib-9x07
- depends = python-misaka-v1
+ depends = python-misaka
depends = python-itsdangerous
depends = python-six
+ depends = python-cffi
depends = sqlite
depends = python-setuptools
backup = etc/isso.conf
- source = https://github.com/posativ/isso/releases/download/0.10.5/isso-0.10.5.tar.gz
- source = https://github.com/posativ/isso/releases/download/0.10.5/isso-0.10.5.tar.gz.asc
+ source = https://github.com/posativ/isso/archive/0.12.2/isso-0.12.2.tar.gz
source = https://raw.githubusercontent.com/posativ/isso/master/LICENSE
source = isso.service
validpgpkeys = 7757B21C0C6E5AE4BC6F6462FD1BA15E0E87FE5C
- sha256sums = 2c4748c5123251ef2e6fd0fa4853c175f3c100071a04e98ed32e1878db55e090
- sha256sums = SKIP
+ sha256sums = b1aafbfda42e9862f6492952865ba85499a23e51bb0afc44b6ea3622ea45ed69
sha256sums = d909d060d71c4d9ce92102fa68aa53c963db9b4b6ca315fa0817eafb07651fe2
sha256sums = 5e625e14f757101dcfa9cdacb18c191d5f6f0324a2c68dc8847cb77e343b7eef
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2a49c8b6977c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+LICENSE
+*.xz
+*.gz
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
index 02985f07b9fa..8fcfddbf9710 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,22 @@
-# Maintainer: yhaupenthal <y dot h plus aur at posteo dot de>
+# Maintainer: Peter Cai <peter at typeblog dot net>
+# Contributor: yhaupenthal <y dot h plus aur at posteo dot de>
# Contributor: Brice Waegeneire <brice dot wge at gmail dot com>
# Contributor: Reventlov <contact+aur@volcanis.me>
pkgname=isso
-pkgver=0.10.5
-pkgrel=3
+pkgver=0.12.2
+pkgrel=1
pkgdesc="A commenting python server similar to Disqus"
arch=('any')
url="http://posativ.org/isso/"
license=('MIT')
-depends=('python-werkzeug' 'python-html5lib-9x07' 'python-misaka-v1' 'python-itsdangerous' 'python-six' 'sqlite' 'python-setuptools')
-makedepends=('git' 'python')
+depends=('python-bleach' 'python-jinja' 'python-werkzeug' 'python-html5lib-9x07' 'python-misaka' 'python-itsdangerous' 'python-six' 'python-cffi' 'sqlite' 'python-setuptools')
+makedepends=('git' 'python' 'python-sphinx')
backup=('etc/isso.conf')
-source=("https://github.com/posativ/isso/releases/download/$pkgver/isso-$pkgver.tar.gz"
- "https://github.com/posativ/isso/releases/download/$pkgver/isso-$pkgver.tar.gz.asc"
+source=("https://github.com/posativ/isso/archive/$pkgver/isso-$pkgver.tar.gz"
"https://raw.githubusercontent.com/posativ/isso/master/LICENSE"
"isso.service")
install=$pkgname.install
-sha256sums=('2c4748c5123251ef2e6fd0fa4853c175f3c100071a04e98ed32e1878db55e090'
- 'SKIP'
+sha256sums=('b1aafbfda42e9862f6492952865ba85499a23e51bb0afc44b6ea3622ea45ed69'
'd909d060d71c4d9ce92102fa68aa53c963db9b4b6ca315fa0817eafb07651fe2'
'5e625e14f757101dcfa9cdacb18c191d5f6f0324a2c68dc8847cb77e343b7eef')
validpgpkeys=("7757B21C0C6E5AE4BC6F6462FD1BA15E0E87FE5C")
@@ -29,6 +28,7 @@ package() {
msg "Starting build..."
cd "${srcdir}/${pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}/" --optimize=1
+ make man
# ... systemd
install -D -m 644 "${srcdir}/isso.service" "${pkgdir}/usr/lib/systemd/system/isso.service"