summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean-Francois Chevrette2020-06-25 13:13:11 -0400
committerJean-Francois Chevrette2020-06-25 13:13:11 -0400
commitacf1a4924d3650cc7dc3bbbf9f487795d4394adc (patch)
treeefe2bfcda2de793685058b2794c71037edc83d43
parent96771848526fbe18415c01fb98307b7aff75af89 (diff)
downloadaur-acf1a4924d3650cc7dc3bbbf9f487795d4394adc.tar.gz
bump to 1.6.3 & add support for aarch64 and armv7h
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ece33cdbfa2..30b38e590f6e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = istio-bin
pkgdesc = An open platform to connect, manage, and secure microservices
- pkgver = 1.6.1
+ pkgver = 1.6.3
pkgrel = 1
url = https://istio.io
arch = x86_64
+ arch = aarch64
+ arch = armv7h
license = Apache
depends = bash
depends = glibc
conflicts = istio
- source = https://github.com/istio/istio/releases/download/1.6.1/istio-1.6.1-linux-amd64.tar.gz
- sha256sums = 5ac280f72515b328ce1b5779f0f00df742bbb3be142fafa935da58b25a2c1caf
+ source = https://github.com/istio/istio/releases/download/1.6.3/istio-1.6.3-linux-amd64.tar.gz
+ sha256sums = a50671068a2e80dd7300d6d9df082da16c82553090f53837527574c979754204
pkgname = istio-bin
diff --git a/PKGBUILD b/PKGBUILD
index 1549cbc34d50..967633cfc9ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,22 @@
_pkgname='istio'
pkgname="${_pkgname}-bin"
-pkgver=1.6.1
+pkgver=1.6.3
pkgrel=1
pkgdesc='An open platform to connect, manage, and secure microservices'
-arch=('x86_64')
+arch=('x86_64' 'aarch64' 'armv7h')
url='https://istio.io'
license=('Apache')
depends=('bash' 'glibc')
-optdepends=()
-makedepends=()
conflicts=("${_pkgname}")
-source=("https://github.com/istio/istio/releases/download/${pkgver}/istio-${pkgver}-linux-amd64.tar.gz")
-sha256sums=('5ac280f72515b328ce1b5779f0f00df742bbb3be142fafa935da58b25a2c1caf')
+
+case "${CARCH}" in
+ x86_64) _CARCH=amd64 && sha256sums=('a50671068a2e80dd7300d6d9df082da16c82553090f53837527574c979754204');;
+ aarch64) _CARCH=arm64 && sha256sums=('25e7e8e2187630f6d28215d29b7c6b0bf716c10055a2e9a13f96dbd9f1cd0724');;
+ armv7h) _CARCH=armv7 && sha256sums=('9d6bedebe180aac3d740b5ed7e285a450f6f052b53ba9fb3be6d27c737750074');;
+esac
+
+source=("https://github.com/istio/istio/releases/download/${pkgver}/istio-${pkgver}-linux-${_CARCH}.tar.gz")
package() {
cd "${srcdir}/${_pkgname}-${pkgver}"