summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKian Kasad2021-02-18 16:07:14 -0800
committerKian Kasad2021-02-18 16:07:14 -0800
commit50d9b3d57416f1e89521a11021b404dcf7bb0b19 (patch)
tree26939dac84ab2b5fdff1efabb19121c16f21a490
parent6167dfbf6c9ab9148f4f7a8b045bd49c73015409 (diff)
downloadaur-50d9b3d57416f1e89521a11021b404dcf7bb0b19.tar.gz
update for isync v1.4.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
-rw-r--r--isync-xdgconfig.diff4
3 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4de6bee4e50..c2db5959ba7e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = isync-config-patched
pkgdesc = IMAP and MailDir mailbox synchronizer - with xdg-compliant config location
- pkgver = 1.3.1
+ pkgver = 1.4.0
pkgrel = 2
url = http://isync.sourceforge.net
arch = x86_64
@@ -9,14 +9,14 @@ pkgbase = isync-config-patched
depends = zlib
provides = isync
conflicts = isync
- source = https://downloads.sourceforge.net/project/isync/isync/1.3.1/isync-1.3.1.tar.gz
- source = https://downloads.sourceforge.net/project/isync/isync/1.3.1/isync-1.3.1.tar.gz.asc
+ source = https://downloads.sourceforge.net/project/isync/isync/1.4.0/isync-1.4.0.tar.gz
+ source = https://downloads.sourceforge.net/project/isync/isync/1.4.0/isync-1.4.0.tar.gz.asc
source = isync-xdgconfig.diff
validpgpkeys = 96DD32BFBF9FAB04B0D95305AA283E0B2F1BB1D1
validpgpkeys = 63BFD037CAD71E8DFF3AEA3AC17714F08D1BDBBA
- md5sums = 58bc3507ebe930f8fec5997430be85d5
+ md5sums = bf60773c0ec03f132aac546df9cc7b87
md5sums = SKIP
- md5sums = 18f7a2734975edd3deb984fadadc3b5a
+ md5sums = 554e0cf7302565f1a76a88e16e4cdb2a
pkgname = isync-config-patched
diff --git a/PKGBUILD b/PKGBUILD
index bf040ac0d86b..311ab82ccfbb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=isync-config-patched
_pkgname=isync
-pkgver=1.3.1
+pkgver=1.4.0
pkgrel=2
pkgdesc="IMAP and MailDir mailbox synchronizer - with xdg-compliant config location"
arch=('x86_64')
@@ -14,9 +14,9 @@ provides=('isync')
source=(https://downloads.sourceforge.net/project/isync/isync/$pkgver/$_pkgname-$pkgver.tar.gz
https://downloads.sourceforge.net/project/isync/isync/$pkgver/$_pkgname-$pkgver.tar.gz.asc
isync-xdgconfig.diff)
-md5sums=('58bc3507ebe930f8fec5997430be85d5'
+md5sums=('bf60773c0ec03f132aac546df9cc7b87'
'SKIP'
- '18f7a2734975edd3deb984fadadc3b5a')
+ '554e0cf7302565f1a76a88e16e4cdb2a')
validpgpkeys=('96DD32BFBF9FAB04B0D95305AA283E0B2F1BB1D1'
'63BFD037CAD71E8DFF3AEA3AC17714F08D1BDBBA')
diff --git a/isync-xdgconfig.diff b/isync-xdgconfig.diff
index d12cfeabca3e..9ed3406cc64a 100644
--- a/isync-xdgconfig.diff
+++ b/isync-xdgconfig.diff
@@ -2,10 +2,10 @@ diff --git a/src/config.c b/src/config.c
index 8ddfe26..537ae11 100644
--- a/src/config.c
+++ b/src/config.c
-@@ -325,7 +325,12 @@ load_config( const char *where, int pseudo )
+@@ -331,7 +331,12 @@ load_config( const char *where )
+ char buf[1024];
if (!where) {
- assert( !pseudo );
- nfsnprintf( path, sizeof(path), "%s/." EXE "rc", Home );
+ char *configdir;
+ configdir = getenv("XDG_CONFIG_HOME");