summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKian Kasad2020-06-28 00:26:34 -0700
committerKian Kasad2020-06-28 00:28:45 -0700
commit8a842b4c2e07a208fd725abcd4846f2ed586cc9d (patch)
tree73b209b9a101d3e5576b4cc7a5dcc71e05e5cbe3
downloadaur-8a842b4c2e07a208fd725abcd4846f2ed586cc9d.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD37
-rw-r--r--isync-xdgconfig.diff18
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c8d7185e323
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = isync-config-patched
+ pkgdesc = IMAP and MailDir mailbox synchronizer - with xdg-compliant config location
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = http://isync.sourceforge.net
+ arch = x86_64
+ license = GPL2
+ depends = libsasl
+ depends = zlib
+ provides = isync
+ conflicts = isync
+ source = https://downloads.sourceforge.net/project/isync/isync/1.3.1/isync-1.3.1.tar.gz
+ source = https://downloads.sourceforge.net/project/isync/isync/1.3.1/isync-1.3.1.tar.gz.asc
+ source = isync-xdgconfig.diff
+ validpgpkeys = 96DD32BFBF9FAB04B0D95305AA283E0B2F1BB1D1
+ validpgpkeys = 63BFD037CAD71E8DFF3AEA3AC17714F08D1BDBBA
+ md5sums = 58bc3507ebe930f8fec5997430be85d5
+ md5sums = SKIP
+ md5sums = 18f7a2734975edd3deb984fadadc3b5a
+
+pkgname = isync-config-patched
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a34439a1107c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Kian Kasad <kian at kasad.com>
+
+pkgname=isync-config-patched
+_pkgname=isync
+pkgver=1.3.1
+pkgrel=1
+pkgdesc="IMAP and MailDir mailbox synchronizer - with xdg-compliant config location"
+arch=('x86_64')
+url="http://isync.sourceforge.net"
+license=('GPL2')
+depends=('libsasl' 'zlib')
+conflicts=('isync')
+provides=('isync')
+source=(https://downloads.sourceforge.net/project/isync/isync/$pkgver/$_pkgname-$pkgver.tar.gz
+ https://downloads.sourceforge.net/project/isync/isync/$pkgver/$_pkgname-$pkgver.tar.gz.asc
+ isync-xdgconfig.diff)
+md5sums=('58bc3507ebe930f8fec5997430be85d5'
+ 'SKIP'
+ '18f7a2734975edd3deb984fadadc3b5a')
+validpgpkeys=('96DD32BFBF9FAB04B0D95305AA283E0B2F1BB1D1'
+ '63BFD037CAD71E8DFF3AEA3AC17714F08D1BDBBA')
+
+build() {
+ cd $_pkgname-$pkgver
+
+ ./configure --prefix=/usr
+
+ make
+}
+
+package() {
+ cd $_pkgname-$pkgver
+
+ make DESTDIR="$pkgdir" install
+}
+
+# vim: ts=8 sts=4 sw=4 et
diff --git a/isync-xdgconfig.diff b/isync-xdgconfig.diff
new file mode 100644
index 000000000000..d12cfeabca3e
--- /dev/null
+++ b/isync-xdgconfig.diff
@@ -0,0 +1,18 @@
+diff --git a/src/config.c b/src/config.c
+index 8ddfe26..537ae11 100644
+--- a/src/config.c
++++ b/src/config.c
+@@ -325,7 +325,12 @@ load_config( const char *where, int pseudo )
+
+ if (!where) {
+ assert( !pseudo );
+- nfsnprintf( path, sizeof(path), "%s/." EXE "rc", Home );
++ char *configdir;
++ configdir = getenv("XDG_CONFIG_HOME");
++ if (configdir == NULL)
++ nfsnprintf( path, sizeof(path), "%s/.config/mbsync/" EXE "rc", Home );
++ else
++ nfsnprintf( path, sizeof(path), "%s/mbsync/" EXE "rc", configdir );
+ cfile.file = path;
+ } else
+ cfile.file = where;