summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmos Wenger2016-05-13 10:24:44 +0000
committerAmos Wenger2016-05-13 10:24:44 +0000
commit8cb14d6d682e2ff3f17eebf8e639b3a913c09454 (patch)
tree2ce72432d3432e8d569f858664de0310ec1fd81f
parent6f2aaa570043a3f6869e9096fb2df6db756d4e71 (diff)
downloadaur-8cb14d6d682e2ff3f17eebf8e639b3a913c09454.tar.gz
:arrow_up: v17.6.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD49
2 files changed, 31 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a033dbb1c146..06dffaa9652c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
# Generated by mksrcinfo v8
-# Wed Apr 20 21:12:50 UTC 2016
+# Fri May 13 10:24:44 UTC 2016
pkgbase = itch
pkgdesc = The best way to play itch.io games.
- pkgver = 0.14.0
+ pkgver = 17.6.0
pkgrel = 1
url = https://github.com/itchio/itch
install = itch.install
arch = i686
arch = x86_64
license = MIT
- makedepends = nodejs-babel-cli
- makedepends = sassc
- makedepends = electron
makedepends = nodejs
makedepends = nodejs-grunt-cli
makedepends = npm
+ makedepends = ruby
depends = alsa-lib
depends = libnotify
depends = nss
@@ -25,8 +23,8 @@ pkgbase = itch
depends = gtk-update-icon-cache
depends = p7zip
options = !strip
- source = https://github.com/itchio/itch/archive/v0.14.0.tar.gz
- sha256sums = 0eafdc5c12f2a007a146b2925dc99c210ee9aeb2c859ce81fa523244098c5779
+ source = https://github.com/itchio/itch/archive/v17.6.0.tar.gz
+ sha256sums = e34a6dc8128dfaf7ce68b001444c5c4d53a9f8b4912d9bd586450ae2d0bd7a6f
pkgname = itch
diff --git a/PKGBUILD b/PKGBUILD
index 8c22cd0ff80a..17da755ddce4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: FrozenCow <frozencow@gmail.com>
+# Maintainer: Amos Wenger <amos@itch.io>
+# Contributor: FrozenCow <frozencow@gmail.com>
pkgname=itch
-pkgver=0.14.0
+pkgver=17.6.0
pkgrel=1
pkgdesc="The best way to play itch.io games."
@@ -10,15 +11,16 @@ url="https://github.com/itchio/itch"
license=('MIT')
depends=('alsa-lib' 'libnotify' 'nss' 'gconf' 'gtk2' 'libxtst' 'desktop-file-utils' 'gtk-update-icon-cache' 'p7zip')
-makedepends=('nodejs' 'nodejs-grunt-cli' 'npm')
+makedepends=('nodejs' 'nodejs-grunt-cli' 'npm' 'ruby')
options=('!strip')
install="itch.install"
+# sic. - source is in itch repo, kitch is a dummy repo for canary-channel github releases
source=("https://github.com/itchio/itch/archive/v${pkgver}.tar.gz")
-sha256sums=('0eafdc5c12f2a007a146b2925dc99c210ee9aeb2c859ce81fa523244098c5779')
+sha256sums=('e34a6dc8128dfaf7ce68b001444c5c4d53a9f8b4912d9bd586450ae2d0bd7a6f')
-[ "$CARCH" = "i686" ] && _ELECTRON_ARCH=ia32
-[ "$CARCH" = "x86_64" ] && _ELECTRON_ARCH=x64
+[ "$CARCH" = "i686" ] && _ELECTRON_ARCH=ia32; _ITCH_ARCH=i386
+[ "$CARCH" = "x86_64" ] && _ELECTRON_ARCH=x64; _ITCH_ARCH=amd64
prepare() {
cd "itch-${pkgver}"
@@ -26,44 +28,45 @@ prepare() {
export PYTHON=/usr/bin/python2
# Get dependencies
- npm install
+ # (npm3's progress indicator is notoriously slow, disable)
+ npm install --no-progress --quiet
}
build() {
- cd "$srcdir/itch-${pkgver}"
- export CI_APPNAME=itch
- export CI_CHANNEL=stable
- export CI_RELEASE_DATE="`date +%Y-%m-%d`"
- release/prepare.sh
- release/generate-itch-desktop.sh
+ cd "${srcdir}/itch-${pkgver}"
+ export CI_BUILD_TAG="v17.6.0"
+ export CI_CHANNEL="stable"
+
+ release/ci-compile.rb
+ release/ci-generate-linux-extras.rb
grunt -v "electron:linux-${_ELECTRON_ARCH}"
}
check() {
- cd "$srcdir/itch-${pkgver}"
+ cd "${srcdir}/itch-${pkgver}"
npm test
}
package() {
- cd "$srcdir/itch-$pkgver"
+ cd "${srcdir}/itch-${pkgver}"
- install -d "$pkgdir/opt/itch"
- cp -a "build/v$pkgver/itch-linux-$_ELECTRON_ARCH/." "${pkgdir}/opt/itch"
+ install -d "${pkgdir}/usr/lib/itch"
+ cp -a "build/v${pkgver}/itch-linux-${_ELECTRON_ARCH}/." "${pkgdir}/usr/lib/itch"
- install -d "$pkgdir/usr/share/applications"
- install -Dm644 release/itch.desktop "${pkgdir}/usr/share/applications/itch.desktop"
+ install -d "${pkgdir}/usr/share/applications"
+ install -Dm644 linux-extras/itch.desktop "${pkgdir}/usr/share/applications/itch.desktop"
- for icon in release/itch-icons/icon*.png
+ for icon in release/images/itch-icons/icon*.png
do
- iconsize="${icon#release/itch-icons/icon}"
+ iconsize="${icon#release/images/itch-icons/icon}"
iconsize="${iconsize%.png}"
- icondir="$pkgdir/usr/share/icons/hicolor/${iconsize}x${iconsize}/apps/"
+ icondir="${pkgdir}/usr/share/icons/hicolor/${iconsize}x${iconsize}/apps/"
install -d "${icondir}"
install -Dm644 "$icon" "$icondir/itch.png"
done
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm755 "release/itch.sh" "${pkgdir}/usr/bin/itch"
+ ln -s "/usr/bin/itch" "${pkgdir}"
}