summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrozenCow2015-12-14 23:25:26 +0100
committerFrozenCow2015-12-14 23:49:49 +0100
commitb815e9ba91cd3e6133da266c120a0c3bdc19ba3a (patch)
treeb565f35f7390efdc72aa4c761818edce270a69c5
downloadaur-b815e9ba91cd3e6133da266c120a0c3bdc19ba3a.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD60
-rw-r--r--itch.install12
3 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31233f255a0b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Mon Dec 14 22:24:51 UTC 2015
+pkgbase = itch
+ pkgdesc = The best way to play itch.io games.
+ pkgver = 0.8.1
+ pkgrel = 1
+ url = https://github.com/itchio/itch
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = nodejs-babel-cli
+ makedepends = sassc
+ depends = electron
+ depends = nodejs
+ source = https://github.com/itchio/itch/archive/v0.8.1.tar.gz
+ sha256sums = 4fcdfeaea692d30590bff4089fe8986492cb324b7020e882e17edf6968021b47
+
+pkgname = itch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb674f07d48c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: FrozenCow <frozencow@gmail.com>
+
+pkgname=itch
+pkgver=0.8.1
+pkgrel=1
+pkgdesc="The best way to play itch.io games."
+
+arch=('i686' 'x86_64')
+url="https://github.com/itchio/itch"
+license=('MIT')
+
+depends=('alsa-lib' 'libnotify' 'nss' 'gconf' 'gtk2' 'libxtst' 'desktop-file-utils' 'gtk-update-icon-cache')
+makedepends=('nodejs-babel-cli' 'sassc' 'electron' 'nodejs')
+options=('!strip')
+install="itch.install"
+
+source=("https://github.com/itchio/itch/archive/v${pkgver}.tar.gz")
+sha256sums=('4fcdfeaea692d30590bff4089fe8986492cb324b7020e882e17edf6968021b47')
+
+[ "$CARCH" = "i686" ] && _ELECTRON_ARCH=ia32
+[ "$CARCH" = "x86_64" ] && _ELECTRON_ARCH=x64
+
+prepare() {
+ cd "itch-${pkgver}"
+
+ export PYTHON=/usr/bin/python2
+
+ # Get dependencies
+ npm install
+}
+
+build() {
+ cd "$srcdir/itch-${pkgver}"
+ release/prepare.sh
+
+ grunt -v "electron:linux-${_ELECTRON_ARCH}"
+}
+
+package() {
+ cd "$srcdir/itch-$pkgver"
+
+ install -d "$pkgdir/opt/itch"
+ cp -a "build/v$pkgver/itch-linux-$_ELECTRON_ARCH/." "${pkgdir}/opt/itch"
+
+ install -d "$pkgdir/usr/share/applications"
+ install -Dm644 release/itch.desktop "${pkgdir}/usr/share/applications/itch.desktop"
+
+ for icon in release/icons/icon*.png
+ do
+ iconsize="${icon#release/icons/icon}"
+ iconsize="${iconsize%.png}"
+ icondir="$pkgdir/usr/share/icons/hicolor/${iconsize}x${iconsize}/apps/"
+ install -d "${icondir}"
+ install -Dm644 "$icon" "$icondir/itch.png"
+ done
+
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ install -Dm755 "release/itch.sh" "${pkgdir}/usr/bin/itch"
+}
diff --git a/itch.install b/itch.install
new file mode 100644
index 000000000000..c317fbaca442
--- /dev/null
+++ b/itch.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}