summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrozenCow2016-05-14 13:13:33 +0200
committerFrozenCow2016-05-14 13:13:33 +0200
commitfb0847a484cd8d35257cde6e5285bd3971008955 (patch)
tree18a406070c4c1b5e0883a2a069a42680e3b5fd43
parent8cb14d6d682e2ff3f17eebf8e639b3a913c09454 (diff)
downloadaur-fb0847a484cd8d35257cde6e5285bd3971008955.tar.gz
fix dependencies and /usr/bin
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06dffaa9652c..38a05d4edb02 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri May 13 10:24:44 UTC 2016
+# Sat May 14 11:13:28 UTC 2016
pkgbase = itch
pkgdesc = The best way to play itch.io games.
pkgver = 17.6.0
@@ -13,6 +13,7 @@ pkgbase = itch
makedepends = nodejs-grunt-cli
makedepends = npm
makedepends = ruby
+ makedepends = ruby-bundler
depends = alsa-lib
depends = libnotify
depends = nss
diff --git a/PKGBUILD b/PKGBUILD
index 17da755ddce4..31c0cd35038a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ url="https://github.com/itchio/itch"
license=('MIT')
depends=('alsa-lib' 'libnotify' 'nss' 'gconf' 'gtk2' 'libxtst' 'desktop-file-utils' 'gtk-update-icon-cache' 'p7zip')
-makedepends=('nodejs' 'nodejs-grunt-cli' 'npm' 'ruby')
+makedepends=('nodejs' 'nodejs-grunt-cli' 'npm' 'ruby' 'ruby-bundler')
options=('!strip')
install="itch.install"
@@ -68,5 +68,6 @@ package() {
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- ln -s "/usr/bin/itch" "${pkgdir}"
+ mkdir -p "${pkgdir}/usr/bin"
+ ln -s "/usr/lib/itch/itch" "${pkgdir}/usr/bin/itch"
}