summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Mattern2016-05-02 18:29:27 +0200
committerPeter Mattern2016-05-02 18:29:27 +0200
commit4217b30501b985791265d21542ac260dd0e7690d (patch)
tree8338bce0e923e84e8f9e3edbffb288bb3e6c2e79
downloadaur-4217b30501b985791265d21542ac260dd0e7690d.tar.gz
Initial commit
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD45
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bbd43b7f57d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+# Generated by mksrcinfo v8
+# Mon May 2 11:05:20 UTC 2016
+pkgbase = itk-git
+ pkgdesc = Open-source, cross-platform C++ toolkit for segmentation and registration
+ pkgver = 4.9.1.511.gf3ac5ea
+ pkgrel = 1
+ url = http://www.itk.org
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ makedepends = cmake
+ makedepends = python
+ makedepends = swig
+ depends = hdf5-cpp-fortran
+ depends = gdcm
+ depends = libjpeg-turbo
+ depends = libpng
+ depends = libtiff
+ provides = itk
+ provides = insight-toolkit
+ provides = insight-toolkit-git
+ conflicts = itk
+ conflicts = insight-toolkit
+ conflicts = insight-toolkit-git
+ source = itk::git://git.code.sf.net/p/itk/code
+ sha256sums = SKIP
+
+pkgname = itk-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4fbd617503ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Peter Mattern <pmattern at arcor dot de>
+
+_pkgname=itk
+pkgname=$_pkgname-git
+pkgver=4.9.1.511.gf3ac5ea
+pkgrel=1
+pkgdesc='Open-source, cross-platform C++ toolkit for segmentation and registration'
+arch=('i686' 'x86_64')
+url='http://www.itk.org'
+license=('Apache')
+depends=('hdf5-cpp-fortran' 'gdcm' 'libjpeg-turbo' 'libpng' 'libtiff')
+makedepends=('git' 'cmake' 'python' 'swig')
+provides=("$_pkgname" "insight-toolkit" "insight-toolkit-git")
+conflicts=("$_pkgname" "insight-toolkit" "insight-toolkit-git")
+source=("$_pkgname::git://git.code.sf.net/p/itk/code")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd $_pkgname
+ git describe --always | sed 's:^v::;s:-:.:g'
+}
+
+build() {
+ mkdir -p build ; cd build
+
+ # All bindings are triggering failure of CMake or make right now, thus temporarily disabling
+
+ cmake $srcdir/$_pkgname \
+ -DBUILD_SHARED_LIBS=ON \
+ -DBUILD_TESTING=OFF \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DITK_USE_SYSTEM_LIBRARIES=ON \
+ -DITK_USE_SYSTEM_GDCM=ON \
+ -DITK_WRAP_JAVA=OFF \
+ -DITK_WRAP_PERL=OFF \
+ -DITK_WRAP_PYTHON=OFF \
+ -DITK_WRAP_RUBY=OFF \
+ -DITK_WRAP_TCL=OFF
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}