summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2018-04-27 08:40:35 +0200
committerMartino Pilia2018-04-27 08:40:35 +0200
commitad6a3143c0786421aefc310f07a773f2e26ccec0 (patch)
tree916aae4ef7d341786a2390d6559839b0b6bd5988
downloadaur-ad6a3143c0786421aefc310f07a773f2e26ccec0.tar.gz
submit package
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD63
-rw-r--r--itkKernelFunction.h61
-rw-r--r--itksnap.desktop10
-rw-r--r--itksnap.pngbin0 -> 30591 bytes
5 files changed, 157 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..decebec6a38f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = itk-snap
+ pkgdesc = ITK-SNAP is a software application used to segment structures in 3D medical images
+ pkgver = 3.6.0
+ pkgrel = 1
+ url = http://www.itksnap.org
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ depends = insight-toolkit
+ depends = vtk
+ depends = qt5-base
+ depends = fltk
+ source = itk-snap::git+git://git.code.sf.net/p/itk-snap/src
+ source = itkKernelFunction.h
+ source = itksnap.png
+ source = itksnap.desktop
+ sha512sums = SKIP
+ sha512sums = 69010fb1d771ce28793a3f546dd7bf10b200d45755e44b77145c49af88291d89778753deb431a523c637ed7c954a73b172f4bbd52baf41b65594454acb6dcad2
+ sha512sums = b5f1e7876a9d0cb7d1abb1f0c19147642b99511d8a052a91053affa51aabd9a3929288fbe7fa365c4ad7042f28edca4759a9f3fb8f48916d1e7ee2023b1e7591
+ sha512sums = bd699dad2ff6704e56b9ac8073d92683060bf9b71ae2218c7dafd272210d8a402db1e08bedc3187e96bb74adb40a2b30b0da92bc34dd3ca40fe05e24d43d247b
+
+pkgname = itk-snap
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8dd1ae86c08e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer of this PKGBUILD file: Martino Pilia <martino.pilia@gmail.com>
+pkgname=itk-snap
+pkgver=3.6.0
+pkgrel=1
+pkgdesc='ITK-SNAP is a software application used to segment structures in 3D medical images'
+arch=('x86_64')
+url='http://www.itksnap.org'
+license=('GPL3')
+depends=('insight-toolkit' 'vtk' 'qt5-base' 'fltk')
+optdepends=()
+makedepends=('cmake')
+source=("$pkgname::git+git://git.code.sf.net/p/itk-snap/src"
+ "itkKernelFunction.h"
+ "itksnap.png"
+ "itksnap.desktop")
+sha512sums=('SKIP'
+ '69010fb1d771ce28793a3f546dd7bf10b200d45755e44b77145c49af88291d89778753deb431a523c637ed7c954a73b172f4bbd52baf41b65594454acb6dcad2'
+ 'b5f1e7876a9d0cb7d1abb1f0c19147642b99511d8a052a91053affa51aabd9a3929288fbe7fa365c4ad7042f28edca4759a9f3fb8f48916d1e7ee2023b1e7591'
+ 'bd699dad2ff6704e56b9ac8073d92683060bf9b71ae2218c7dafd272210d8a402db1e08bedc3187e96bb74adb40a2b30b0da92bc34dd3ca40fe05e24d43d247b')
+
+_release_commit='562f52acab8668bae681e206b20d559e59e2ef37'
+
+prepare() {
+ cd "$srcdir/$pkgname"
+
+ git checkout $_release_commit
+
+ # Replace relative with absolute location of the repo
+ sed -i 's,../../c3d/git,git://git.code.sf.net/p/c3d/git,' .gitmodules
+
+ git submodule init
+ git submodule update
+
+ mkdir build || :
+ cd build
+
+ # Ship a deprecated ITKv3 compatibility header
+ # The v3 compatibility module will be soon removed from ITK 5.0,
+ # so better to not add it as a dependency
+ mkdir itkv3 || :
+ cp "$srcdir/itkKernelFunction.h" itkv3/.
+
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_CXX_FLAGS="-fPIC -I'$srcdir/$pkgname/build/itkv3' -DITKV3_COMPATIBILITY=1" \
+ -DBUILD_OUTSIDE_INSIGHT_APPLICATIONS=ON \
+ -DBUILD_TESTING=OFF \
+ -DFLTK_FLUID_EXECUTABLE="/usr/bin/fluid"
+}
+
+build() {
+ cd "$srcdir/$pkgname/build"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname/build"
+ make install DESTDIR="$pkgdir"
+
+ install -D -m644 "$srcdir/itksnap.png" "${pkgdir}/usr/share/icons/hicolor/128x128/apps/itksnap.png"
+ install -D -m644 "$srcdir/itksnap.desktop" "${pkgdir}/usr/share/applications/itksnap.desktop"
+}
+
diff --git a/itkKernelFunction.h b/itkKernelFunction.h
new file mode 100644
index 000000000000..509f78778ff1
--- /dev/null
+++ b/itkKernelFunction.h
@@ -0,0 +1,61 @@
+/*=========================================================================
+ *
+ * Copyright Insight Software Consortium
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0.txt
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ *
+ *=========================================================================*/
+#ifndef __itkKernelFunction_h
+#define __itkKernelFunction_h
+
+#include "itkKernelFunctionBase.h"
+
+#ifndef ITKV3_COMPATIBILITY
+#error "This file is only valid when ITKV3_COMPATIBILITY is turned on. Users are encouraged to convert to itkKernelFunctionBase.h in ITKv4"
+#endif
+
+namespace itk
+{
+/** \class KernelFunction
+ * \brief KernelFunction is for backward compatibility with ITKv3
+ *
+ * \deprecated
+ * \ingroup Functions
+ * \ingroup ITKV3Compatibility
+ */
+class ITKCommon_EXPORT KernelFunction:public KernelFunctionBase< double >
+{
+public:
+ /** Standard class typedefs. */
+ typedef KernelFunction Self;
+ typedef KernelFunctionBase< double > Superclass;
+ typedef SmartPointer< Self > Pointer;
+ typedef SmartPointer< const Self > ConstPointer;
+
+ typedef Superclass::RealType RealType;
+
+ /** Run-time type information (and related methods). */
+ itkTypeMacro(KernelFunction, FunctionBase);
+
+ /** Evaluate the function. Subclasses must implement this. */
+ virtual RealType Evaluate(const RealType & u) const = 0;
+
+protected:
+ KernelFunction() {};
+ virtual ~KernelFunction() {};
+ void PrintSelf(std::ostream & os, Indent indent) const
+ { Superclass::PrintSelf(os, indent); }
+};
+} // end namespace itk
+
+#endif // __itkKernelFunction_h
diff --git a/itksnap.desktop b/itksnap.desktop
new file mode 100644
index 000000000000..feedca6eb726
--- /dev/null
+++ b/itksnap.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=3.6.0
+Name=ITK-Snap
+Comment=ITK-SNAP is a software application used to segment structures in 3D medical images.
+Exec=/usr/bin/itksnap
+Icon=itksnap
+Categories=Science;
+Type=Application
+Terminal=false
+StartupNotify=false
diff --git a/itksnap.png b/itksnap.png
new file mode 100644
index 000000000000..04c8e3448ac6
--- /dev/null
+++ b/itksnap.png
Binary files differ