summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2023-03-01 12:22:11 +0800
committerlilac2023-03-01 12:22:11 +0800
commit0b91b3ea920e3aa5a02466e05c2c848ca08d45d7 (patch)
treeb359382a1927d725f46208e0085f3fe7d808af1a
parentc084a6213bdaf09f4aaadc28fbfe9e42e18cb926 (diff)
downloadaur-0b91b3ea920e3aa5a02466e05c2c848ca08d45d7.tar.gz
[lilac] updated to 4.0.0-2
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 20 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50f82d85c59f..8b41349bfba4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,17 @@
pkgbase = itk-snap-bin
pkgdesc = A software application used to segment structures in 3D medical images
- pkgver = 3.8.0
- pkgrel = 1
+ pkgver = 4.0.0
+ pkgrel = 2
url = https://www.itksnap.org
arch = x86_64
license = GPL
makedepends = gendesk
- depends = curl
depends = glib2
- depends = libpng12
provides = itk-snap
conflicts = itk-snap
- source = itk-snap-bin-3.8.0.tar.gz::https://sourceforge.net/projects/itk-snap/files/itk-snap/3.8.0/itksnap-3.8.0-20190612-Linux-x86_64.tar.gz
- source = itk-snap.png::https://sourceforge.net/p/itk-snap/src/ci/master/tree/GUI/Qt/Resources/logo_square.png?format=raw
- sha512sums = c76247387f6e4c5fe0dfaee7147167429352994a6903e772e6e2cf6a3a91bce92d9d34b6a0905a929bfa206854650438503d2da58abeb4966503d42ce42ea79b
+ source = itk-snap-bin-4.0.0.tar.gz::https://sourceforge.net/projects/itk-snap/files/itk-snap/4.0.0/itksnap-4.0.0-20230220-Linux-gcc64.tar.gz
+ source = itk-snap.png::https://github.com/pyushkevich/itksnap/raw/master/GUI/Qt/Resources/logo_square.png
+ sha512sums = 6f5899521de673d6b5d1230ec25963221d631b8ca60fcf841b225282162ed3838f7392a536a91db1b611e1578d7e06b60de3d1fa6b6fdcfcfec373a3d27b4921
sha512sums = 7d7866a4f28ee645cf4a454488d197a776475d2959d0f9d4d34cf534f34a73ffbb1b92430518f36948b4c25b736990693be07dd345600ed8292e526e2846fca1
pkgname = itk-snap-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index 672894f254f6..0d89da4ed559 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,31 @@
pkgname=itk-snap-bin
_pkgname=itk-snap
-pkgver=3.8.0
-_pkgver=3.8.0
-pkgrel=1
+pkgver=4.0.0
+_pkgver=4.0.0
+_date=20230220
+pkgrel=2
pkgdesc="A software application used to segment structures in 3D medical images"
arch=('x86_64')
url="https://www.itksnap.org"
license=('GPL')
-depends=('curl' 'glib2' 'libpng12')
-makedepends=('gendesk')
+depends=(
+ glib2
+)
+makedepends=(
+ gendesk
+)
provides=('itk-snap')
conflicts=('itk-snap')
source=(
- "${pkgname}-${pkgver}.tar.gz::https://sourceforge.net/projects/itk-snap/files/itk-snap/3.8.0/itksnap-3.8.0-20190612-Linux-x86_64.tar.gz"
- "${_pkgname}.png::https://sourceforge.net/p/itk-snap/src/ci/master/tree/GUI/Qt/Resources/logo_square.png?format=raw"
+ "${pkgname}-${pkgver}.tar.gz::https://sourceforge.net/projects/itk-snap/files/itk-snap/${pkgver}/itksnap-${pkgver}-${_date}-Linux-gcc64.tar.gz"
+ "${_pkgname}.png::https://github.com/pyushkevich/itksnap/raw/master/GUI/Qt/Resources/logo_square.png"
)
-sha512sums=('c76247387f6e4c5fe0dfaee7147167429352994a6903e772e6e2cf6a3a91bce92d9d34b6a0905a929bfa206854650438503d2da58abeb4966503d42ce42ea79b'
+sha512sums=('6f5899521de673d6b5d1230ec25963221d631b8ca60fcf841b225282162ed3838f7392a536a91db1b611e1578d7e06b60de3d1fa6b6fdcfcfec373a3d27b4921'
'7d7866a4f28ee645cf4a454488d197a776475d2959d0f9d4d34cf534f34a73ffbb1b92430518f36948b4c25b736990693be07dd345600ed8292e526e2846fca1')
prepare() {
- msg2 "Creating desktop file"
+ echo "Creating desktop file"
gendesk -f -n --pkgname ${_pkgname} \
--pkgdesc "${pkgdesc}" \
--categories "Education;Graphics;Science;DataVisualization;MedicalSoftware;Viewer" \
@@ -30,7 +35,7 @@ prepare() {
}
package() {
install -d "${pkgdir}/usr"
- mv "${srcdir}/itksnap-${_pkgver}-20190612-Linux-gcc64/"* "${pkgdir}/usr"
+ mv "${srcdir}/itksnap-${_pkgver}-${_date}-Linux-gcc64/"* "${pkgdir}/usr"
install -Dm644 "${srcdir}/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
install -Dm644 "${srcdir}/${_pkgname}.png" "${pkgdir}/usr/share/pixmaps/${_pkgname}.png"
}