summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuval Adam2016-01-30 01:44:48 +0200
committerYuval Adam2016-01-30 01:44:48 +0200
commit620cb405c85c02f6ee561b5296f086dce5b52ad3 (patch)
tree8853e36f200fc364aab8a82f9ea3277a5a726532
downloadaur-620cb405c85c02f6ee561b5296f086dce5b52ad3.tar.gz
Add itpp from AUR3
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a84ba97e86c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = itpp
+ pkgdesc = C++ library of mathematical, signal processing and communication routines
+ pkgver = 4.3.1
+ pkgrel = 1
+ url = http://itpp.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ depends = blas
+ depends = lapack
+ depends = fftw
+ depends = perl
+ source = http://downloads.sourceforge.net/project/itpp/itpp/4.3.1/itpp-4.3.1.tar.bz2
+ md5sums = 94f3dac6df2bb829819d0aa99b501933
+
+pkgname = itpp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11156602f273
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Yuval Adam <yuval at y3xz dot com> PGP-Key: 271386AA2EB7672F
+# Contributor: Maxime de Roucy <maxime.deroucy@gmail.com>
+# Contributor: Joel Schaerer <joel.schaerer@laposte.net>
+
+pkgname=itpp
+pkgver=4.3.1
+pkgrel=1
+pkgdesc="C++ library of mathematical, signal processing and communication routines"
+arch=('i686' 'x86_64')
+url="http://itpp.sourceforge.net/"
+license=('GPL')
+depends=('blas' 'lapack' 'fftw' 'perl')
+makedepends=('cmake')
+source=("http://downloads.sourceforge.net/project/itpp/itpp/${pkgver}/itpp-${pkgver}.tar.bz2")
+md5sums=('94f3dac6df2bb829819d0aa99b501933')
+
+
+build() {
+ cd itpp-$pkgver
+ mkdir -p build
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "itpp-$pkgver/build"
+ make DESTDIR="$pkgdir" install
+}