summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Abernethy2015-07-03 18:54:19 +0200
committerPhilip Abernethy2015-07-03 18:54:19 +0200
commit8d7bd35e2307062fe54cbaee0856acbf168eae63 (patch)
treea2b8f333336a38b4640775af0f1a08bb0c6cecf8
downloadaur-ittledew.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..da6dcdb74532
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ittledew
+ pkgdesc = A 2D adventure in the style of classic Zelda games
+ pkgver = 1.4
+ pkgrel = 1
+ url = http://www.ittledew.com/
+ arch = x86
+ arch = x86_64
+ license = custom:commercial
+ source = hib://ittledew_Linux_1.4.zip
+ sha512sums = e5e792a20a02bff33d351ea378ff10356ebf1c6d23df8ded0d6750d5173ab6cc652473c37cbb6aa0c83f5372b9c24608f0d32e22da0a04ad465c81e1ba01096e
+
+pkgname = ittledew
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c4d1b669b5ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Philip Abernethy<chais.z3r0@gmail.com>
+pkgname='ittledew'
+pkgver='1.4'
+pkgrel=1
+pkgdesc='A 2D adventure in the style of classic Zelda games'
+arch=('x86' 'x86_64')
+url='http://www.ittledew.com/'
+license=('custom:commercial')
+DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Manually download it to \"$(pwd)\", or set up a hib:// DLAGENT in /etc/makepkg.conf."; exit 1')
+
+source=("hib://ittledew_Linux_${pkgver}.zip")
+sha512sums=('e5e792a20a02bff33d351ea378ff10356ebf1c6d23df8ded0d6750d5173ab6cc652473c37cbb6aa0c83f5372b9c24608f0d32e22da0a04ad465c81e1ba01096e')
+
+package() {
+ mkdir -p $pkgdir/{opt,usr/{bin,share/applications}}
+ mv "$srcdir/ittledew_Linux_${pkgver}" "$pkgdir/opt/$pkgname"
+ ln -s /opt/$pkgname/IttleDew_linux.x86 $pkgdir/usr/bin/$pkgname
+ echo "[Desktop Entry]
+Type=Application
+Name=Ittle Dew
+GenericName=Ittle Dew
+Comment=$pkgdesc
+Icon=/opt/$pkgname/IttleDew_linux_Data/Resources/UnityPlayer.png
+Exec=/usr/bin/$pkgname
+Categories=Game;
+Path=/opt/$pkgname" > $pkgdir/usr/share/applications/${pkgname}.desktop
+}