summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiří Klimeš2020-01-28 13:58:55 +0100
committerJiří Klimeš2020-01-28 14:17:08 +0100
commit1cc7547a5b8dedf75aca9fb9734fc9d6eb7beda2 (patch)
tree548394fe5e21c660c24e70260fef1168bc0ab38c
parentcb5a22f2547f94c29d1b61432ed0fb027b4cbffd (diff)
downloadaur-1cc7547a5b8dedf75aca9fb9734fc9d6eb7beda2.tar.gz
Fix build for missing gmodule
srcscintilla/scintilla/gtk/PlatGTK.cxx uses g_module_open() function that is in libgmodule-2.0. The library has to be required explicitly. Unfortunately, tecmake.mak's pkg-config command doesn't do that. This commit should be reverted once the upstream tecmake.mak is fixed.
-rw-r--r--PKGBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1f06666685a9..47e4aa56f7a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -50,6 +50,9 @@ prepare() {
# Add RUN_PATH variable to be able to set DT_RUNPATH
sed 's/$(ECHO)$(LINKER)/& $(RUN_PATH)/' -i "$srcdir"/iup/tecmake.mak
sed 's/$(ECHO)$(LD)/& $(RUN_PATH)/' -i "$srcdir"/iup/tecmake.mak
+
+ # Add required gmodule-2.0 to pkg-config (temporary patch to build successfully)
+ sed '/PKGLIBS += $(shell pkg-config --libs gtk+-$(GTKSFX).0 gdk-$(GTKSFX).0)/{ s/\(.*\))/\1 gmodule-2.0)/ }' -i "$srcdir"/iup/tecmake.mak
}
_lua_iup_build_helper() {