summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMika Attila2015-06-19 13:46:28 +0200
committerMika Attila2015-06-19 13:46:28 +0200
commit89975c749bcdc1adb953f9b005f9f499bb3f64d4 (patch)
treeb298df92706c8e5512f80c167830419e9e85a0e4
downloadaur-89975c749bcdc1adb953f9b005f9f499bb3f64d4.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD55
-rw-r--r--makfiles.patch78
3 files changed, 156 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..81f8085b2a0f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = iup
+ pkgdesc = C cross platform GUI toolkit
+ pkgver = 3.14
+ pkgrel = 1
+ url = http://www.tecgraf.puc-rio.br/iup/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = libcd
+ optdepends = lua: bindings for Lua are available
+ optdepends = cd: for additional controls support
+ optdepends = im: for advanced imaging support
+ optdepends = mesa: for OpenGL support
+ options = staticlibs
+ source = http://downloads.sourceforge.net/project/iup/3.14/Docs%20and%20Sources/iup-3.14_Sources.tar.gz
+ source = http://heanet.dl.sourceforge.net/project/iup/3.14/Docs%20and%20Sources/iup-3.14_Docs.pdf
+ source = makfiles.patch
+ md5sums = fce0f918d6e48a01521173f7f8b687a1
+ md5sums = 3c96de1263691a5a6b42bcadb12513f2
+ md5sums = 9c50f5376fe5cc0f459ec0148c452c57
+
+pkgname = iup
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7794068fd704
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Contributor: Lex Black <autumn-wind at web dot de>
+# Contributor: Karro <karolina.lindqvist@kramnet.se>
+# Contributor: maoserr
+#
+# Maintainer: SneakySnake <radiantstatue@gmail.com>
+# Submit issues/pull requests at https://github.com/crumblingstatue/pkgbuilds
+
+pkgname=iup
+pkgver=3.14
+pkgrel=1
+pkgdesc="C cross platform GUI toolkit"
+arch=('i686' 'x86_64')
+url="http://www.tecgraf.puc-rio.br/iup/"
+license=('MIT')
+depends=('libcd')
+optdepends=('lua: bindings for Lua are available'
+ 'cd: for additional controls support'
+ 'im: for advanced imaging support'
+ 'mesa: for OpenGL support')
+options=(staticlibs)
+
+source=(
+ "http://downloads.sourceforge.net/project/iup/${pkgver}/Docs%20and%20Sources/iup-${pkgver}_Sources.tar.gz"
+ "http://heanet.dl.sourceforge.net/project/iup/${pkgver}/Docs%20and%20Sources/iup-${pkgver}_Docs.pdf"
+ makfiles.patch
+)
+
+md5sums=(
+ 'fce0f918d6e48a01521173f7f8b687a1'
+ '3c96de1263691a5a6b42bcadb12513f2'
+ '9c50f5376fe5cc0f459ec0148c452c57'
+)
+
+prepare() {
+ cd $srcdir/$pkgname
+ patch -b -p0 <../makfiles.patch
+}
+
+build() {
+ cd $srcdir/$pkgname
+ make iup iupcd iupcontrols iupgl iup_pplot iupim iupimglib ledc iupview
+}
+
+package() {
+ cd $srcdir/$pkgname
+
+ install -m755 -d $pkgdir/usr/lib
+ install -m644 $srcdir/iup/lib/Linux*/* $pkgdir/usr/lib
+ install -m755 -d $pkgdir/usr/share/$pkgname
+ install -m644 $srcdir/iup-${pkgver}_Docs.pdf $pkgdir/usr/share/$pkgname
+ install -m755 -d $pkgdir/usr/include/iup
+ install -m644 $srcdir/iup/include/* $pkgdir/usr/include/iup
+ mkdir -p $pkgdir/usr/share/licenses/iup
+ install -m644 $srcdir/iup/COPYRIGHT $pkgdir/usr/share/licenses/iup
+}
diff --git a/makfiles.patch b/makfiles.patch
new file mode 100644
index 000000000000..53f9ba429c3e
--- /dev/null
+++ b/makfiles.patch
@@ -0,0 +1,78 @@
+--- tecmake.mak.orig 2015-04-30 04:20:54.000000000 +0200
++++ tecmake.mak 2015-05-19 12:53:18.852399934 +0200
+@@ -916,12 +916,12 @@
+ endif
+
+ ifdef USE_LUA
+- LUA_LIB ?= $(LUA)/lib/$(TEC_UNAME_LIB_DIR)
++ LUA_LIB ?= /usr/lib
+ ifdef USE_STATIC
+ ifndef NO_LUALIB
+ SLIB += $(LUA_LIB)/liblualib$(LUA_SUFFIX).a
+ endif
+- SLIB += $(LUA_LIB)/liblua$(LUA_SUFFIX).a
++ SLIB += $(LUA_LIB)/liblua.a
+ else
+ ifndef NO_LUALIB
+ LIBS += lualib$(LUA_SUFFIX)
+@@ -931,7 +931,7 @@
+ LDIR += $(LUA_LIB)
+ else
+ ifneq ($(findstring cygw, $(TEC_UNAME)), )
+- LIBS += lua$(LUA_SUFFIX)
++ LIBS += lua
+ LDIR += $(LUA_LIB)
+ endif
+ endif
+@@ -1040,7 +1040,7 @@
+ LINK_CAIRO = Yes
+ endif
+
+- SLIB += $(CD_LIB)/libcd$(CD_SUFFIX).a
++ SLIB += /usr/lib/libcd.a
+ else
+ ifdef USE_XRENDER
+ CHECK_XRENDER = Yes
+@@ -1075,7 +1075,7 @@
+
+ LINK_FREETYPE = Yes
+
+- CD_INC ?= $(CD)/include
++ CD_INC ?= /usr/include/cd
+ INCLUDES += $(CD_INC)
+ endif
+
+@@ -1087,13 +1087,13 @@
+ endif
+
+ ifdef USE_STATIC
+- SLIB += $(IM_LIB)/libim.a
++ SLIB += /usr/lib/libim.a
+ else
+ LIBS += im
+ LDIR += $(IM_LIB)
+ endif
+
+- IM_INC ?= $(IM)/include
++ IM_INC ?= /usr/include/im
+ INCLUDES += $(IM_INC)
+ endif
+
+@@ -1134,7 +1134,7 @@
+ ZLIB_LIB = $(CD_LIB)
+ endif
+
+- SLIB += $(ZLIB_LIB)/lib$(ZLIB).a
++ SLIB += /usr/lib/libz.a
+ else
+ LIBS += $(ZLIB)
+ endif
+@@ -1292,7 +1292,7 @@
+ endif
+
+ ifdef USE_X11
+- LIBS += $(X11_LIBS)
++ LIBS += $(X11_LIBS) fontconfig
+ LDIR += $(X11_LIB)
+ STDINCS += $(X11_INC)
+ endif