summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiří Klimeš2020-08-07 13:00:50 +0200
committerJiří Klimeš2020-08-07 13:16:15 +0200
commite2691e497d32672468077c53e6dbb3f6f6208d74 (patch)
tree84fb4972235036bc95b897745475c3653c85f4ba
parent4b116d77331d3b424b6cf2b1e8f63503a23e37cc (diff)
downloadaur-e2691e497d32672468077c53e6dbb3f6f6208d74.tar.gz
Fix building iupweb library
iupweb library uses iupStrFileMakeURL() function from iup_str.c, so it has to include the object file. (temporary patch to build successfully - remove when fixed upstream)
-rw-r--r--PKGBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 65e628a351ab..997718c68b64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -54,6 +54,9 @@ prepare() {
# Add required gmodule-2.0 to pkg-config (temporary patch to build successfully)
sed '/PKGLIBS += $(shell pkg-config --libs gtk+-$(GTKSFX).0 gdk-$(GTKSFX).0/ { s/\(.*\))/\1 gmodule-2.0)/ }' -i "$srcdir"/iup/tecmake.mak
+
+ # Fix building iupweb library (temporary patch to build successfully)
+ sed 's|SRC = iup_webbrowser.c|SRC = iup_webbrowser.c ../src/iup_str.c|' -i "$srcdir"/iup/srcweb/config.mak
}
_lua_iup_build_helper() {