summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre LALET2017-08-07 17:07:24 +0200
committerPierre LALET2017-08-07 17:07:24 +0200
commit07960eb7379c805ad8354db738a0620aa1b312bc (patch)
tree2b85627fd99814a3e3e30029ed58636e7b77603e
parent0c84dd2bd57b4ecbdc4ca8a8f74d15e2c497d436 (diff)
downloadaur-07960eb7379c805ad8354db738a0620aa1b312bc.tar.gz
Update sha256sum
This hash change is due to the use of gitattributes in the file ivre/__init__.py. Just after the release, the string '$Format:%h %D$' is evaluated to '[COMMIT HASH] HEAD -> master, tag: v[VERSION]'. When a new commit is pushed to master, the same string is evaluated to '[COMMIT HASH] tag: v[VERSION]'. The result is exactly the same, since 'tag: v0.9.6' is always present (see diff below for some context), but this causes the sha256sum to differ. --- orig/ivre-0.9.6/ivre/__init__.py 2017-06-26 19:10:14.000000000 +0200 +++ new/ivre-0.9.6/ivre/__init__.py 2017-06-26 19:10:14.000000000 +0200 @@ -72,7 +72,7 @@ def _version(): return fdesc.read() except IOError: pass - hashval, refnames = u'e5dff0d7 HEAD -> master, tag: v0.9.6'.split(' ', 1) + hashval, refnames = u'e5dff0d7 tag: v0.9.6'.split(' ', 1) try: return next(ref[6:] for ref in refnames.split(u', ') if ref.startswith(u'tag: v')) except StopIteration:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
2 files changed, 2 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d49c72650957..d8e7a9188804 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -33,7 +33,7 @@ pkgbase = ivre
backup = etc/httpd/conf/extra/ivre.conf
source = https://github.com/cea-sec/ivre/archive/v0.9.6.tar.gz
source = apache.example.conf
- sha256sums = d82d20ec0dc8fcb8e521061636b99367faf5c2bf2051c6dfaa85fac8abf72f3b
+ sha256sums = 4b8cda9dfb05493ee19fd334e7872bff39333b623974e6eafa976ec938d84d07
sha256sums = 3e372f51f2ad441baf8268ce29d35b3a1cb9ef4cb29e7864fab389759694f72e
pkgname = ivre
diff --git a/PKGBUILD b/PKGBUILD
index 182023fd1618..8889cd45f335 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -32,7 +32,7 @@ makedepends=('python-setuptools')
backup=('etc/httpd/conf/extra/ivre.conf')
source=(https://github.com/cea-sec/$pkgname/archive/v$pkgver.tar.gz
'apache.example.conf')
-sha256sums=('d82d20ec0dc8fcb8e521061636b99367faf5c2bf2051c6dfaa85fac8abf72f3b'
+sha256sums=('4b8cda9dfb05493ee19fd334e7872bff39333b623974e6eafa976ec938d84d07'
'3e372f51f2ad441baf8268ce29d35b3a1cb9ef4cb29e7864fab389759694f72e')
build() {