summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre Lalet2020-05-24 13:27:19 +0200
committerPierre Lalet2020-05-24 13:27:19 +0200
commit6b6205e582995b0acaaa9ba7cb15322a782e0cb1 (patch)
treed8f32b3ea6c54a614e1bf74aa639fc83bc82c949
parent08aefa5c1808d7ee173f2e19a3b14063ad3d9013 (diff)
downloadaur-6b6205e582995b0acaaa9ba7cb15322a782e0cb1.tar.gz
Version update
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD13
2 files changed, 15 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3851db8cbccd..a122356302ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = ivre-git
pkgdesc = Network recon framework based on Nmap, Masscan, Zeek (Bro), Argus, Netflow,...
- pkgver = 0.9.14.dev64
+ pkgver = 0.9.15.dev44
pkgrel = 1
url = https://ivre.rocks/
arch = any
license = GPL3
makedepends = git
+ makedepends = python
+ makedepends = python2
source = git+https://github.com/cea-sec/ivre.git
sha512sums = SKIP
@@ -46,14 +48,16 @@ pkgname = python-ivre-git
depends = python
depends = python-pymongo
depends = python-future
+ depends = python-pyopenssl
+ depends = python-cryptography
optdepends = python-py2neo: experimental flow analysis (Neo4j backend)
optdepends = python-sqlalchemy: experimental PostgreSQL & SQLite backends
optdepends = python-psycopg2: experimental PostgreSQL backend
optdepends = python-elasticsearch: experimental Elasticsearch backend
optdepends = python-elasticsearch-dsl: experimental Elasticsearch backend
+ optdepends = python-tinydb: experimental file-based backend (no DB server)
optdepends = python-pillow: trim screenshots on insertion
optdepends = tesseract: extract words from screenshots on insertion
- optdepends = python-pycryptodome: extract data from public keys ("ivre getmoduli")
optdepends = python-scapy: parse PCAP files for ARP inspection (flow analysis)
optdepends = python-matplotlib: create graphs from command line tools
optdepends = python-dbus: 3D traceroute graphs
@@ -68,14 +72,16 @@ pkgname = python2-ivre-git
depends = python2
depends = python2-pymongo
depends = python2-future
+ depends = python2-pyopenssl
+ depends = python2-cryptography
optdepends = python2-py2neo: experimental flow analysis (Neo4j backend)
optdepends = python2-sqlalchemy: experimental PostgreSQL & SQLite backends
optdepends = python2-psycopg2: experimental PostgreSQL backend
optdepends = python2-elasticsearch: experimental Elasticsearch backend
optdepends = python2-elasticsearch-dsl: experimental Elasticsearch backend
+ optdepends = python2-tinydb: experimental file-based backend (no DB server)
optdepends = python2-pillow: trim screenshots on insertion
optdepends = tesseract: extract words from screenshots on insertion
- optdepends = python2-pycryptodome: extract data from public keys ("ivre getmoduli")
optdepends = python2-scapy: parse PCAP files for ARP inspection (flow analysis)
optdepends = python2-matplotlib: create graphs from command line tools
optdepends = python2-dbus: 3D traceroute graphs
diff --git a/PKGBUILD b/PKGBUILD
index e58dfe432628..c19c70462b6c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgbase=ivre-git
_pkgname=ivre
pkgname=('ivre-git' 'ivre-web-git' 'ivre-docs-git' 'python-ivre-git' 'python2-ivre-git')
-pkgver=0.9.14.dev64
+pkgver=0.9.15.dev44
pkgrel=1
pkgdesc='Network recon framework based on Nmap, Masscan, Zeek (Bro), Argus, Netflow,...'
arch=('any')
url='https://ivre.rocks/'
license=('GPL3')
-makedepends=('git')
+makedepends=('git' 'python' 'python2')
source=('git+https://github.com/cea-sec/ivre.git')
sha512sums=('SKIP')
@@ -96,7 +96,6 @@ package_ivre-web-git() {
rm -r "$pkgdir/usr/bin" "$pkgdir/usr/lib" \
"$pkgdir/usr/share/doc" \
- "$pkgdir/usr/share/ivre/bro" \
"$pkgdir/usr/share/ivre/zeek" \
"$pkgdir/usr/share/ivre/data" \
"$pkgdir/usr/share/ivre/docker" \
@@ -110,15 +109,15 @@ package_ivre-web-git() {
}
package_python-ivre-git() {
- depends=('python' 'python-pymongo' 'python-future')
+ depends=('python' 'python-pymongo' 'python-future' 'python-pyopenssl' 'python-cryptography')
optdepends=('python-py2neo: experimental flow analysis (Neo4j backend)'
'python-sqlalchemy: experimental PostgreSQL & SQLite backends'
'python-psycopg2: experimental PostgreSQL backend'
'python-elasticsearch: experimental Elasticsearch backend'
'python-elasticsearch-dsl: experimental Elasticsearch backend'
+ 'python-tinydb: experimental file-based backend (no DB server)'
'python-pillow: trim screenshots on insertion'
'tesseract: extract words from screenshots on insertion'
- 'python-pycryptodome: extract data from public keys ("ivre getmoduli")'
'python-scapy: parse PCAP files for ARP inspection (flow analysis)'
'python-matplotlib: create graphs from command line tools'
'python-dbus: 3D traceroute graphs'
@@ -141,15 +140,15 @@ package_python-ivre-git() {
}
package_python2-ivre-git() {
- depends=('python2' 'python2-pymongo' 'python2-future')
+ depends=('python2' 'python2-pymongo' 'python2-future' 'python2-pyopenssl' 'python2-cryptography')
optdepends=('python2-py2neo: experimental flow analysis (Neo4j backend)'
'python2-sqlalchemy: experimental PostgreSQL & SQLite backends'
'python2-psycopg2: experimental PostgreSQL backend'
'python2-elasticsearch: experimental Elasticsearch backend'
'python2-elasticsearch-dsl: experimental Elasticsearch backend'
+ 'python2-tinydb: experimental file-based backend (no DB server)'
'python2-pillow: trim screenshots on insertion'
'tesseract: extract words from screenshots on insertion'
- 'python2-pycryptodome: extract data from public keys ("ivre getmoduli")'
'python2-scapy: parse PCAP files for ARP inspection (flow analysis)'
'python2-matplotlib: create graphs from command line tools'
'python2-dbus: 3D traceroute graphs'