summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLászló Várady2019-03-10 20:14:59 +0100
committerLászló Várady2019-03-10 20:14:59 +0100
commit55c54dbe15a7bfa6b828407e0926c7115a050d53 (patch)
tree9f419134efdd76ace282ca63326a8f28fc274300
downloadaur-55c54dbe15a7bfa6b828407e0926c7115a050d53.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8931c236bd61
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ivykis
+ pkgdesc = Asynchronous I/O readiness notification library
+ pkgver = 0.42.3
+ pkgrel = 1
+ url = https://github.com/buytenh/ivykis
+ arch = x86_64
+ license = LGPL2.1
+ conflicts = libivykis
+ conflicts = libivykis-git
+ source = https://downloads.sourceforge.net/project/libivykis/0.42.3/ivykis-0.42.3.tar.gz
+ sha256sums = c9b025d55cefe9c58958d1012f36d63aa0a5caf22075617fff648751ea940aec
+
+pkgname = ivykis
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5fdb8acfd9b3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*.tar.xz
+/*.tar.gz
+/src
+/pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..61634ca97f17
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: László Várady <laszlo.varady93@gmail.com>
+
+pkgname=ivykis
+pkgver=0.42.3
+pkgrel=1
+pkgdesc="Asynchronous I/O readiness notification library"
+arch=('x86_64')
+url="https://github.com/buytenh/ivykis"
+license=('LGPL2.1')
+conflicts=('libivykis' 'libivykis-git')
+source=("https://downloads.sourceforge.net/project/lib$pkgname/$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('c9b025d55cefe9c58958d1012f36d63aa0a5caf22075617fff648751ea940aec')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make --keep-going check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}