summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJameson Pugh2017-01-16 10:49:45 -0500
committerJameson Pugh2017-01-16 10:49:45 -0500
commit7e9d01035847bfe7d41bb71622ac9fb8ed332f10 (patch)
tree58fbb199f4be0872003fc22cff763f04377f7728
downloadaur-7e9d01035847bfe7d41bb71622ac9fb8ed332f10.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD42
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca354a3151ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Mon Jan 16 15:49:41 UTC 2017
+pkgbase = iwd-git
+ pkgdesc = Internet Wireless Daemon
+ pkgver = r1755.8bacbf0
+ pkgrel = 1
+ url = https://git.kernel.org/cgit/network/wireless/iwd.git/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ depends = glibc
+ provides = iwd
+ conflicts = iwd
+ source = git+https://git.kernel.org/pub/scm/network/wireless/iwd.git
+ source = git+https://git.kernel.org/pub/scm/libs/ell/ell.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = iwd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..79267b78e6e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Jameson Pugh <imntreal@gmail.com>
+
+pkgname=iwd-git
+pkgver=r1755.8bacbf0
+pkgrel=1
+pkgdesc='Internet Wireless Daemon'
+arch=('i686' 'x86_64')
+url='https://git.kernel.org/cgit/network/wireless/iwd.git/'
+license=('LGPL')
+depends=('glibc')
+makedepends=('git')
+provides=('iwd')
+conflicts=('iwd')
+source=('git+https://git.kernel.org/pub/scm/network/wireless/iwd.git'
+ 'git+https://git.kernel.org/pub/scm/libs/ell/ell.git')
+sha256sums=('SKIP' 'SKIP')
+_gitname='iwd'
+
+pkgver() {
+ cd "${_gitname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+}
+
+prepare() {
+ cd "${srcdir}/${_gitname}"
+ ./bootstrap
+}
+
+build() {
+ cd "${srcdir}/${_gitname}"
+
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+
+ make install DESTDIR="${pkgdir}"
+}
+
+# vim: set ts=2 sw=2 ft=sh noet: