summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoramtoaer2020-09-27 10:18:07 +0800
committeramtoaer2020-09-27 10:18:07 +0800
commitdbd166517d5df54b4c8efd6e2987091c40ecd478 (patch)
tree63fff46bbb6f01de422ce2e88df93cacdbd0d83c
downloadaur-dbd166517d5df54b4c8efd6e2987091c40ecd478.tar.gz
release 1.0.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0655254333ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = iwsp-bin
+ pkgdesc = Northeastern University Gymnasium Reservation.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/amtoaer/iwsp
+ arch = x86_64
+ license = MIT
+ source = iwsp-linux::https://github.com/amtoaer/iwsp/releases/download/1.0.0/iwsp-linux
+ source = LICENSE::https://raw.githubusercontent.com/amtoaer/iwsp/master/LICENSE
+ md5sums = 83b33c2f1fe52182de9777d751cf803e
+ md5sums = 31fad0aacc583d621612630ce8f5a26c
+
+pkgname = iwsp-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c9192dff318
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: amtoaer <amtoaer@outlook.com>
+pkgname=iwsp-bin
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Northeastern University Gymnasium Reservation."
+arch=('x86_64')
+url="https://github.com/amtoaer/iwsp"
+license=('MIT')
+
+source=(
+ "iwsp-linux::https://github.com/amtoaer/iwsp/releases/download/${pkgver}/iwsp-linux"
+ "LICENSE::https://raw.githubusercontent.com/amtoaer/iwsp/master/LICENSE"
+)
+
+md5sums=(
+ '83b33c2f1fe52182de9777d751cf803e'
+ '31fad0aacc583d621612630ce8f5a26c'
+)
+
+package(){
+ install -D -m 755 /iwsp-linux /usr/bin/iwsp
+ install -D -m 644 /LICENSE /usr/share/licenses/iwsp/LICENSE
+}