summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-09-08 15:24:30 +0000
committerDaniel Bermond2020-09-08 15:24:30 +0000
commit780eb40c69c4da391583719d1afe4a71983e15e4 (patch)
tree3b40baff7b46c0622c797c1d0cfd9f6c5c69b3ed
parentf9ed204d36563400007554c9ec2cf3fa2c9d9b45 (diff)
downloadaur-780eb40c69c4da391583719d1afe4a71983e15e4.tar.gz
Cosmetic changes
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 5 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 10afa65265fc..f74069000d91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = izpack
pkgdesc = Tool for packaging applications on the Java platform as cross-platform installers
pkgver = 5.1.3
- pkgrel = 1
+ pkgrel = 2
url = http://izpack.org/
arch = any
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index b9aafd0e15bf..678997974f94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=izpack
pkgver=5.1.3
-pkgrel=1
+pkgrel=2
pkgdesc='Tool for packaging applications on the Java platform as cross-platform installers'
arch=('any')
url='http://izpack.org/'
@@ -30,9 +30,7 @@ build() {
}
check() {
- mvn -f "${pkgname}-${pkgname}-${pkgver}" \
- -Dproject.build.outputTimestamp="$SOURCE_DATE_EPOCH" \
- test
+ mvn -f "${pkgname}-${pkgname}-${pkgver}" test
}
package() {
@@ -65,8 +63,8 @@ package() {
local _res
while read -r -d '' _file
do
- _res="$(printf '%s' "$_file" | sed 's/\.png$//;s/^.*_//')"
- _dest="$(printf '%s' "$_file" | sed ";s/_${_res}//;s/_/-/")"
+ _res="$(sed 's/\.png$//;s/^.*_//' <<< "$_file")"
+ _dest="$(sed ";s/_${_res}//;s/_/-/" <<< "$_file")"
mkdir -p "${pkgdir}/usr/share/icons/hicolor/${_res}x${_res}/mimetypes"
ln -s "../../../../../../opt/izpack/icons/${_file}" \
"${pkgdir}/usr/share/icons/hicolor/${_res}x${_res}/mimetypes/${_dest}"