summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorphyskets2019-03-16 12:32:15 +0530
committerphyskets2019-03-16 12:32:15 +0530
commit81757fddcd33c69d277ada81c6798e58c074e627 (patch)
tree0cf00b5f6bae0aab713236fc22de2db99c60abbd
parent683b769dedc596a396d157aa5b960e730d80ce47 (diff)
downloadaur-81757fddcd33c69d277ada81c6798e58c074e627.tar.gz
update, signature addition & shift to optdepends
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
2 files changed, 18 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e5af895b845..bbf53a3efd9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,20 @@
pkgbase = j4-dmenu-desktop
pkgdesc = A much faster replacement for i3-dmenu-desktop. Its purpose is to find .desktop files and offer you a menu to start an application using dmenu.
- pkgver = 2.16
+ pkgver = 2.17
pkgrel = 1
url = https://github.com/enkore/j4-dmenu-desktop
arch = any
license = GPL3
makedepends = git
makedepends = cmake
- depends = dmenu
+ optdepends = dmenu: install for the default backend
+ optdepends = bemenu: an alternative backend
conflicts = j4-dmenu-desktop-git
- source = j4-dmenu-desktop-r2.16.tar.gz::https://github.com/enkore/j4-dmenu-desktop/archive/r2.16.tar.gz
- sha256sums = cce03564227677ffbf0d1a15588247904c4fce997bc21bb92e1147a916b6c520
+ source = j4-dmenu-desktop-r2.17.tar.gz::https://github.com/enkore/j4-dmenu-desktop/archive/r2.17.tar.gz
+ source = https://github.com/enkore/j4-dmenu-desktop/releases/download/r2.17/j4-dmenu-desktop-r2.17.tar.gz.sig
+ validpgpkeys = A1774C1B37DC1DCEDB65EE469B8450B91D1362C1
+ sha256sums = 78f6e5a534d8b675ee9fcdd4d5a61f18125089af2b094306fdaca72795ba5f49
+ sha256sums = SKIP
pkgname = j4-dmenu-desktop
diff --git a/PKGBUILD b/PKGBUILD
index c8c73c7f4ac1..9e358544a8d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,25 @@
# Maintainer: Dimitrios Vogiatzis <me@dimtree.net>
+# Maintainer: physkets <physkets // at // tutanota dot com>
# Contributor: Justin Dray <justin@dray.be>
# Contributor: Bill Kolokithas <kolokithas.b@gmail.com>
pkgname=j4-dmenu-desktop
-pkgver=2.16
+pkgver=2.17
pkgrel=1
pkgdesc="A much faster replacement for i3-dmenu-desktop. Its purpose is to find .desktop files and offer you a menu to start an application using dmenu."
arch=('any')
url="https://github.com/enkore/j4-dmenu-desktop"
license=('GPL3')
-depends=('dmenu')
+optdepends=('dmenu: install for the default backend'
+ 'bemenu: an alternative backend')
makedepends=('git' 'cmake')
conflicts=('j4-dmenu-desktop-git')
-source=("${pkgname}-r${pkgver}.tar.gz::https://github.com/enkore/j4-dmenu-desktop/archive/r${pkgver}.tar.gz")
-sha256sums=('cce03564227677ffbf0d1a15588247904c4fce997bc21bb92e1147a916b6c520')
+source=("${pkgname}-r${pkgver}.tar.gz::${url}/archive/r${pkgver}.tar.gz"
+ "${url}/releases/download/r${pkgver}/${pkgname}-r${pkgver}.tar.gz.sig")
+validpgpkeys=('A1774C1B37DC1DCEDB65EE469B8450B91D1362C1') # Marian Beermann <public@enkore.de>
+sha256sums=('78f6e5a534d8b675ee9fcdd4d5a61f18125089af2b094306fdaca72795ba5f49'
+ 'SKIP')
+
build() {
cd ${pkgname}-r${pkgver}