summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Dray2015-05-28 13:07:38 +1000
committerJustin Dray2015-05-28 13:07:38 +1000
commit994e1a66944664a993444bbb6568fd355d80f471 (patch)
tree467430dbacf9577389e93e9ed454732ce3a6cf8a
downloadaur-994e1a66944664a993444bbb6568fd355d80f471.tar.gz
Cleaned up organization for arch packages in prep for aur4
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c6e3c413cd7c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = j4-dmenu-desktop
+ pkgdesc = A much faster replacement for i3-dmenu-desktop. It's purpose is to find .desktop files and offer you a menu to start an application using dmenu.
+ pkgver = 2.12
+ pkgrel = 1
+ url = https://github.com/enkore/j4-dmenu-desktop
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ depends = dmenu
+ conflicts = j4-dmenu-desktop-git
+ source = https://github.com/enkore/j4-dmenu-desktop/archive/r2.12.zip
+ md5sums = 52f023363f530908fe9612b1ada3a861
+
+pkgname = j4-dmenu-desktop
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a611751a8a82
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Justin Dray <justin@dray.be>
+# Contributor: Bill Kolokithas <kolokithas.b@gmail.com>
+
+pkgname=j4-dmenu-desktop
+pkgver=2.12
+pkgrel=1
+pkgdesc="A much faster replacement for i3-dmenu-desktop. It's purpose is to find .desktop files and offer you a menu to start an application using dmenu."
+arch=('i686' 'x86_64')
+url="https://github.com/enkore/j4-dmenu-desktop"
+license=('GPL3')
+depends=('dmenu')
+makedepends=('git' 'cmake')
+conflicts=('j4-dmenu-desktop-git')
+source=("https://github.com/enkore/j4-dmenu-desktop/archive/r${pkgver}.zip")
+md5sums=('52f023363f530908fe9612b1ada3a861')
+
+prepare() {
+ # Patch for issue #20; backported as it was not included for the 2.11 cut
+ # Can probably be removed from v2.12 onwards
+ sed -i '/include <string>/s/$/\n#include <functional>/' "$srcdir/j4-dmenu-desktop-r$pkgver/src/Formatters.hh"
+
+ # Patch for issue #21; backported as it was not included for the 2.11 cut
+ # Can probably be removed from v2.12 onwards
+ sed -i '/endif(NOT DEFINED/s/^/\nadd_dependencies(j4-dmenu-tests catch)\n/' "$srcdir/j4-dmenu-desktop-r$pkgver/CMakeLists.txt"
+}
+build() {
+ cd ${pkgname}-r${pkgver}
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd ${pkgname}-r${pkgver}
+ make DESTDIR="$pkgdir/" install
+}