summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormrdotx2023-03-24 09:08:00 +0100
committermrdotx2023-03-24 09:08:00 +0100
commit4b0e5495e24a5c6d5c7f5a2ee783e8ebe6a274d6 (patch)
treed9712e054b4659ec8982f1ef06a62611aa01de66
parentcb75c15ebd44604efae7c2efcaf1f89447405bd7 (diff)
downloadaur-4b0e5495e24a5c6d5c7f5a2ee783e8ebe6a274d6.tar.gz
pkgbuild fixed and .gitignore added
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD27
2 files changed, 20 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9fa5b5ded80b..dada876f46c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = j4-dmenu-desktop-git
pkgdesc = A rewrite of i3-dmenu-desktop, which is much faster
- pkgver = 2.12.r9.gebe007a
+ pkgver = 2.18.r11.g7a64862
pkgrel = 1
url = https://github.com/enkore/j4-dmenu-desktop
arch = i686
@@ -8,11 +8,11 @@ pkgbase = j4-dmenu-desktop-git
license = GPL3
makedepends = git
makedepends = cmake
- depends = dmenu
+ optdepends = dmenu
+ optdepends = bemenu
provides = j4-dmenu-desktop
conflicts = j4-dmenu-desktop
- source = git://github.com/enkore/j4-dmenu-desktop
+ source = j4-dmenu-desktop-git::git+https://github.com/enkore/j4-dmenu-desktop.git
md5sums = SKIP
pkgname = j4-dmenu-desktop-git
-
diff --git a/PKGBUILD b/PKGBUILD
index f30a6eddd7e3..72f1c076cb46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,37 @@
-# Maintainer: Bill Kolokithas <kolokithas.b@gmail.com>
-
-_gitname=j4-dmenu-desktop
-pkgname=$_gitname-git
-pkgver=2.12.r9.gebe007a
+# Maintainer: mrdotx <klassiker@gmx.de>
+# Contributor: shulhan <ms@kilabit.info>
+# Contributor: Bill Kolokithas <kolokithas.b@gmail.com>
+pkgname=j4-dmenu-desktop-git
+pkgver=2.18.r11.g7a64862
pkgrel=1
pkgdesc="A rewrite of i3-dmenu-desktop, which is much faster"
arch=('i686' 'x86_64')
url="https://github.com/enkore/j4-dmenu-desktop"
license=('GPL3')
-depends=('dmenu')
-makedepends=('git' 'cmake')
+makedepends=(
+ 'git'
+ 'cmake')
+optdepends=(
+ 'dmenu'
+ 'bemenu'
+)
provides=('j4-dmenu-desktop')
conflicts=('j4-dmenu-desktop')
-source=("git://github.com/enkore/j4-dmenu-desktop")
+source=("$pkgname::git+https://github.com/enkore/j4-dmenu-desktop.git")
md5sums=('SKIP')
pkgver() {
- cd $_gitname
+ cd $pkgname
git describe --long | sed -r 's/^r//;s/([^-]*-g)/r\1/;s/-/./g'
}
build() {
- cd $_gitname
+ cd $pkgname
cmake -DCMAKE_INSTALL_PREFIX=/usr -DNO_TESTS=1 .
make
}
package() {
- cd $_gitname
+ cd $pkgname
make DESTDIR="$pkgdir"/ install
}