summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormrdotx2023-03-24 14:24:34 +0100
committermrdotx2023-03-24 14:24:34 +0100
commita52c4123c61c82493beb57068d55e2ff473d347a (patch)
tree0044ea42112d735446bb35a68f57992f096ec175
parent7104db424643afe83ba264568290549dc234ff52 (diff)
downloadaur-a52c4123c61c82493beb57068d55e2ff473d347a.tar.gz
minor structural changes
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 570d3b35e96e..979ab424b8c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = j4-dmenu-desktop-git
pkgdesc = A rewrite of i3-dmenu-desktop, which is much faster
pkgver = 2.18.r11.g7a64862
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/enkore/j4-dmenu-desktop
arch = i686
arch = x86_64
@@ -12,7 +12,7 @@ pkgbase = j4-dmenu-desktop-git
optdepends = bemenu: an alternative backend
provides = j4-dmenu-desktop
conflicts = j4-dmenu-desktop
- source = j4-dmenu-desktop-git::git+https://github.com/enkore/j4-dmenu-desktop.git
+ source = git+https://github.com/enkore/j4-dmenu-desktop.git
md5sums = SKIP
pkgname = j4-dmenu-desktop-git
diff --git a/PKGBUILD b/PKGBUILD
index 4a5d2ddfd4c8..b62504329c2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: mrdotx <klassiker@gmx.de>
# Contributor: shulhan <ms@kilabit.info>
# Contributor: Bill Kolokithas <kolokithas.b@gmail.com>
+_pkgname=j4-dmenu-desktop
pkgname=j4-dmenu-desktop-git
pkgver=2.18.r11.g7a64862
-pkgrel=3
-pkgdesc="A rewrite of i3-dmenu-desktop, which is much faster"
+pkgrel=4
+pkgdesc='A rewrite of i3-dmenu-desktop, which is much faster'
arch=('i686' 'x86_64')
-url="https://github.com/enkore/j4-dmenu-desktop"
+url='https://github.com/enkore/j4-dmenu-desktop'
license=('GPL3')
makedepends=(
'git'
@@ -17,21 +18,21 @@ optdepends=(
)
provides=('j4-dmenu-desktop')
conflicts=('j4-dmenu-desktop')
-source=("$pkgname::git+https://github.com/enkore/j4-dmenu-desktop.git")
+source=('git+https://github.com/enkore/j4-dmenu-desktop.git')
md5sums=('SKIP')
pkgver() {
- cd $pkgname
+ cd "$_pkgname"
git describe --long | sed -r 's/^r//;s/([^-]*-g)/r\1/;s/-/./g'
}
build() {
- cd $pkgname
+ cd "$_pkgname"
cmake -DCMAKE_INSTALL_PREFIX=/usr -DNO_TESTS=1 .
make
}
package() {
- cd $pkgname
+ cd "$_pkgname"
make DESTDIR="$pkgdir"/ install
}