summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavion2015-06-09 09:38:38 +1000
committerXavion2015-06-09 09:38:38 +1000
commita9b677918fcee0c7f7456f8d70a414458261fa26 (patch)
tree9668a247d45b2b83317dbb5bd4c3798cefa7e2d5
downloadaur-a9b677918fcee0c7f7456f8d70a414458261fa26.tar.gz
Initial AUR v4 importation
-rw-r--r--.SRCINFO25
-rw-r--r--J7Z.install58
-rw-r--r--PKGBUILD47
3 files changed, 130 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e2d42b902a84
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = j7z
+ pkgdesc = An alternative 7-Zip GUI
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = http://J7Z.Xavion.name
+ install = J7Z.install
+ arch = any
+ license = LGPL3
+ depends = java-runtime>=7
+ depends = p7zip
+ optdepends = gtk-kde4: KDE style support
+ optdepends = oxygen-gtk: Native 'Oxygen' style
+ optdepends = tar: Supports POSIX attributes
+ optdepends = gzip: Supports GZip archives
+ optdepends = bzip2: Supports BZip2 archives
+ optdepends = xz: Supports XZ archives
+ conflicts = q7z
+ conflicts = k7z
+ replaces = q7z
+ replaces = k7z
+ source = http://prdownloads.sourceforge.net/k7z/J7Z-1.3.0-bin.tar.bz2
+ sha1sums = 830623317ffdae88c82a1eefc6f0b760113a8c7d
+
+pkgname = j7z
+
diff --git a/J7Z.install b/J7Z.install
new file mode 100644
index 000000000000..ebc9f0d6bbeb
--- /dev/null
+++ b/J7Z.install
@@ -0,0 +1,58 @@
+# J7Z: Installer: Arch
+# Contributor: Xavion <Xavion (dot) 0 (at) Gmail (dot) com>
+
+post_install() {
+ # Change file permissions
+ #chmod 777 /usr/share/J7Z/Source/
+
+ # Remove old files
+ user_remove
+
+ #/bin/true
+}
+
+post_upgrade() {
+ post_install
+ #/bin/true
+}
+
+pre_remove() {
+ /bin/true
+}
+
+user_remove() {
+ # User
+ if [ ${USER} ]; then
+ export USER=${LOGNAME}
+ fi
+
+ # Home
+ if [ ${SUDO_USER} ]; then
+ export HOME=/home/${SUDO_USER}
+ else
+ export HOME=/home/${USER}
+ fi
+
+ # KDE
+ rm -f ${HOME}/.kde*/share/kde4/services/ServiceMenus/?7Z*
+ rm -f ${HOME}/.kde*/share/apps/konqueror/servicemenus/?7Z*
+
+ # Gnome
+ rm -rf ${HOME}/.gnome2/nautilus-scripts/?7Z*
+
+ # Xfce
+ rm -f ${HOME}/.config/Thunar/uca.xml.?7Z
+}
+
+post_remove() {
+ #rm -rf /usr/share/J7Z/
+
+ user_remove
+
+ #/bin/true
+}
+
+op=$1
+shift
+
+$op "$@"
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ceee9cbf8f11
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Xavion <Xavion (dot) 0 (at) Gmail (dot) com>
+
+pkgname=j7z
+_filename_=J7Z
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="An alternative 7-Zip GUI"
+arch=("any")
+url="http://${_filename_}.Xavion.name"
+license=("LGPL3")
+depends=("java-runtime>=7" "p7zip")
+#makedepends=("apache-ant" "java-environment>=7")
+optdepends=("gtk-kde4: KDE style support"
+ "oxygen-gtk: Native 'Oxygen' style"
+ "tar: Supports POSIX attributes"
+ "gzip: Supports GZip archives"
+ "bzip2: Supports BZip2 archives"
+ "xz: Supports XZ archives")
+conflicts=("q7z" "k7z")
+replaces=("q7z" "k7z")
+install="${_filename_}.install"
+#source=(http://prdownloads.sourceforge.net/k7z/${_filename_}-${pkgver}-src.tar.bz2)
+source=(http://prdownloads.sourceforge.net/k7z/${_filename_}-${pkgver}-bin.tar.bz2)
+
+build() {
+ cd "${srcdir}"/${_filename_}/Linux/Build
+
+ # Environment
+ source /etc/profile.d/jre.sh || source /etc/profile.d/jdk.sh
+ #source /etc/profile.d/apache-ant.sh
+
+ #make uninstall
+ #make clean
+ make
+}
+
+package() {
+ cd "${srcdir}"/${_filename_}/Linux/Build
+
+ make Packaging=1 DESTDIR="${pkgdir}" install
+
+ # Messages
+ msg "Seek further information or send feedback via the 'Help' menu."
+}
+
+#sha1sums=('7d7fc964de1e6323c6323b960eb3425859ae744a')
+sha1sums=('830623317ffdae88c82a1eefc6f0b760113a8c7d')