summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Wiesner2022-11-06 11:34:45 +0100
committerSebastian Wiesner2022-11-06 11:52:50 +0100
commit4a8bd0bd3a6b1dc740123d94d3b1eda41a8aa518 (patch)
tree81818fd333cc2ea7dd84d088c338d763b4a1de3a
parentc5a20ad0fb552b5020a691821368fb73f32d5a1b (diff)
downloadaur-4a8bd0bd3a6b1dc740123d94d3b1eda41a8aa518.tar.gz
Download all dependencies directly
Do not download anything during the actual build
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD24
2 files changed, 30 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 70aac711770a..abc2687aa4da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,6 +9,7 @@ pkgbase = ja2-stracciatella-git
makedepends = cargo
makedepends = cmake
makedepends = ninja
+ makedepends = string-theory
depends = sdl2
depends = sdl2>2.0.6
depends = fltk
@@ -18,6 +19,13 @@ pkgbase = ja2-stracciatella-git
provides = ja2-stracciatella
conflicts = ja2-stracciatella
source = git+https://github.com/ja2-stracciatella/ja2-stracciatella.git
- md5sums = SKIP
+ source = https://github.com/Neargye/magic_enum/releases/download/v0.7.3/magic_enum.hpp
+ source = https://github.com/mackron/miniaudio/archive/c153a947919808419b0bf3f56b6f2ee606d6c5f4.tar.gz
+ sha256sums = SKIP
+ sha256sums = 903f026fedfff836619b78e10ce4a352fff314ba801aba672a4b509735e38540
+ sha256sums = 5feb82b4ed59196aabac7325339621b49caddc078b86399d1a0b5425177462a9
+ b2sums = SKIP
+ b2sums = 054a8de35818f3217b157601b3402ed8bc62c203e726f74ca5c696a36520429d05213fc742c675e6c7980226a9604c2ed7602b1284834fb7bf9fae6fac9fc2dd
+ b2sums = 8518478e2adc5f7c0e122b82abb576b3795d1fc7918df09e1d2a0f9a0d31b46f9d1d57536119baf73981af487b51d9336ba753d83e9ecd0a19e9d7f391b27de6
pkgname = ja2-stracciatella-git
diff --git a/PKGBUILD b/PKGBUILD
index dbb635c5defe..728339beb6d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,9 +9,22 @@ license=('custom')
conflicts=('ja2-stracciatella')
provides=('ja2-stracciatella')
depends=('sdl2' 'sdl2>2.0.6' 'fltk' 'rapidjson' 'lua53' 'sol2')
-makedepends=('git' 'cargo' 'cmake' 'ninja')
-source=('git+https://github.com/ja2-stracciatella/ja2-stracciatella.git')
-md5sums=('SKIP')
+makedepends=('git' 'cargo' 'cmake' 'ninja' 'string-theory')
+_magic_enum_ver='0.7.3'
+# This is version 0.11.1; miniaudio doesn't do tags apparently
+_miniaudio_commit='c153a947919808419b0bf3f56b6f2ee606d6c5f4'
+source=(
+ 'git+https://github.com/ja2-stracciatella/ja2-stracciatella.git'
+ # Header-only dependencies of JA2
+ "https://github.com/Neargye/magic_enum/releases/download/v${_magic_enum_ver}/magic_enum.hpp"
+ "https://github.com/mackron/miniaudio/archive/${_miniaudio_commit}.tar.gz"
+)
+sha256sums=('SKIP'
+ '903f026fedfff836619b78e10ce4a352fff314ba801aba672a4b509735e38540'
+ '5feb82b4ed59196aabac7325339621b49caddc078b86399d1a0b5425177462a9')
+b2sums=('SKIP'
+ '054a8de35818f3217b157601b3402ed8bc62c203e726f74ca5c696a36520429d05213fc742c675e6c7980226a9604c2ed7602b1284834fb7bf9fae6fac9fc2dd'
+ '8518478e2adc5f7c0e122b82abb576b3795d1fc7918df09e1d2a0f9a0d31b46f9d1d57536119baf73981af487b51d9336ba753d83e9ecd0a19e9d7f391b27de6')
pkgver() {
cd "${srcdir}/ja2-stracciatella"
@@ -27,6 +40,11 @@ build() {
-DLOCAL_LUA_LIB=OFF \
-DLOCAL_SOL_LIB=OFF \
-DLOCAL_RAPIDJSON_LIB=OFF \
+ -DLOCAL_STRING_THEORY_LIB=OFF \
+ -DLOCAL_MAGICENUM_LIB=OFF \
+ -DMAGICENUM_INCLUDE_DIR="${srcdir}" \
+ -DLOCAL_MINIAUDIO_LIB=OFF \
+ -DMINIAUDIO_INCLUDE_DIR="${srcdir}/miniaudio-${_miniaudio_commit}" \
-DWITH_UNITTESTS=OFF \
"${srcdir}/ja2-stracciatella"
cmake --build build