summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Wiesner2022-11-06 11:52:54 +0100
committerSebastian Wiesner2022-11-06 11:52:54 +0100
commit8415abb50e105addcc3ae7a406966c41d0587d75 (patch)
tree7c7d6327f36d874ba0d26ce692e72f090f2d4909
parentf5102862fda744ba4d53b242ac31f0b53f7c8038 (diff)
downloadaur-8415abb50e105addcc3ae7a406966c41d0587d75.tar.gz
Fix version to consider tags
Unfortunately this doesn't update cleanly because the previous version did not follow VCS packaging guidelines and omitted the r prefix to designate the entire version as revision number. Hence it created a ridicuously high version far ahead of any kind of tag. Regardless we should fix this to get this right for the future.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eef9d3ede480..fde2012f28f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ja2-stracciatella-git
pkgdesc = Jagged Alliance 2 Stracciatella
- pkgver = 11237.829db5183
+ pkgver = v0.20.0.r5.gc6e64c8b4
pkgrel = 1
url = https://github.com/ja2-stracciatella/ja2-stracciatella
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 3b304629a4aa..5b60a07d1518 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Sebastian Wiesner <sebastian@swsnr.de>
# Contributor: Lukas Jirkovsky <l.jirkovsky@gmail.com>
pkgname=ja2-stracciatella-git
-pkgver=11237.829db5183
+pkgver=v0.20.0.r5.gc6e64c8b4
pkgrel=1
pkgdesc='Jagged Alliance 2 Stracciatella'
arch=('x86_64')
@@ -29,7 +29,7 @@ b2sums=('SKIP'
pkgver() {
cd "${srcdir}/ja2-stracciatella"
- echo $(git rev-list --count master).$(git rev-parse --short master)
+ git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {