summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikola Milinković2015-06-21 13:45:00 +0200
committerNikola Milinković2015-06-21 13:45:00 +0200
commit02b0e27f84061b57d4d3199f45a98a673bc537c1 (patch)
tree9255220fa4789e50af81bbc32a9ea39956a12472
parent9a1615fddddeb4dea158b0e40ef984de1a2aedc3 (diff)
downloadaur-02b0e27f84061b57d4d3199f45a98a673bc537c1.tar.gz
Removed a patch due to upstream fix. Removed unneeded dependencies.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD13
-rw-r--r--ant-classpath.patch22
3 files changed, 3 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d02dfde65b54..482e284ae5a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,6 @@ pkgbase = jabref-git
arch = any
license = GPL
makedepends = git
- makedepends = apache-ant
depends = java-environment
depends = sh
provides = jabref
@@ -14,11 +13,9 @@ pkgbase = jabref-git
source = jabref::git+https://github.com/JabRef/jabref.git
source = jabref.desktop
source = jabref.sh
- source = ant-classpath.patch
md5sums = SKIP
md5sums = 5f76feb6b2f66a2ea8b52bca999a934f
md5sums = 9da2f8a5010e25bb04c81225309cc9e5
- md5sums = 261ee0e47d07640f61a2de1d30f58283
pkgname = jabref-git
diff --git a/PKGBUILD b/PKGBUILD
index 95c9bbe03833..59edd41237b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,28 +10,21 @@ arch=('any')
url="http://jabref.sourceforge.net/"
license=('GPL')
depends=('java-environment' 'sh')
-makedepends=('git' 'apache-ant')
+makedepends=('git')
provides=('jabref')
conflicts=('jabref')
-source=('jabref::git+https://github.com/JabRef/jabref.git' 'jabref.desktop' 'jabref.sh' 'ant-classpath.patch')
+source=('jabref::git+https://github.com/JabRef/jabref.git' 'jabref.desktop' 'jabref.sh')
md5sums=('SKIP'
'5f76feb6b2f66a2ea8b52bca999a934f'
- '9da2f8a5010e25bb04c81225309cc9e5'
- '261ee0e47d07640f61a2de1d30f58283')
+ '9da2f8a5010e25bb04c81225309cc9e5')
pkgver() {
cd $_gitname
git describe --tags|sed 's/-/./g'| cut -c3-
}
-prepare() {
- cd "$srcdir/$_gitname"
- patch -p1 -i "$srcdir/ant-classpath.patch"
-}
-
build() {
cd "$srcdir/$_gitname"
- /etc/profile.d/apache-ant.sh
./gradlew antTargets.addgitinfo generateSource antTargets.jars
}
diff --git a/ant-classpath.patch b/ant-classpath.patch
deleted file mode 100644
index 9a1163b00fb4..000000000000
--- a/ant-classpath.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 990e2ab837c66b6070848a40e2e3335d6aef27a0 Mon Sep 17 00:00:00 2001
-From: nikmilpv <nikmil@gmail.com>
-Date: Sun, 21 Jun 2015 01:07:32 +0200
-Subject: [PATCH] Fixed typo that prevented ant builds
-
----
- build.gradle | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/build.gradle b/build.gradle
-index 0160f5c..44fc963 100644
---- a/build.gradle
-+++ b/build.gradle
-@@ -97,7 +97,7 @@ dependencies {
- // use ant targets with prefix antTargets.XXXXX
- ant.importBuild "build-wrapper.xml"
- // add jars from this classpath to the classpath for the ant build
--ant.references.jars.setFiles(configurations.compile.asPath.replace(";"," "))
-+ant.references.jars.setFiles(configurations.compile.asPath.replace(":"," "))
-
- sourceCompatibility = 1.6
- mainClassName = "net.sf.jabref.JabRefMain"