summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2020-10-16 22:03:53 +0200
committerChristopher Arndt2020-10-16 22:03:53 +0200
commitce8e81c81ce14ce0f84ac4e6b9ddd33501d461a2 (patch)
tree44e29fe57af17df7ba8f6b2f838c24f3ef69af2c
parenta868dd0322ac5585dd81bfcfa470fd833dfb88a1 (diff)
downloadaur-ce8e81c81ce14ce0f84ac4e6b9ddd33501d461a2.tar.gz
Sync with community package; check out master branch
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD18
3 files changed, 34 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fdac836f755d..b88ed557bc7b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jack2-git
pkgdesc = C++ version of the JACK low-latency audio server for multi-processor machines
- pkgver = 1.9.13.r3.g3c340b81
+ pkgver = 1.9.16.r0.g5b78c2ef
pkgrel = 1
epoch = 1
url = http://jackaudio.org/
@@ -8,18 +8,25 @@ pkgbase = jack2-git
groups = pro-audio
license = GPL2
license = LGPL2.1
+ makedepends = alsa-lib
+ makedepends = celt
+ makedepends = dbus
makedepends = git
makedepends = libffado
- makedepends = portaudio
+ makedepends = libsamplerate
+ makedepends = libsndfile
+ makedepends = readline
+ makedepends = systemd-libs
makedepends = waf
- depends = celt
+ depends = db
+ depends = expat
depends = opus
- depends = libsamplerate
optdepends = a2jmidid: Expose legacy ALSA sequencer applications in JACK MIDI
optdepends = libffado: Firewire support
optdepends = portaudio: Portaudio support
optdepends = python-dbus: For jack_control
optdepends = realtime-privileges: Acquire realtime privileges
+ optdepends = zita-ajbridge: for using multiple ALSA devices
provides = jack
provides = jack2
provides = libjack.so
@@ -28,8 +35,18 @@ pkgbase = jack2-git
conflicts = jack
conflicts = jack2
replaces = jack2-dbus-git
- source = jack2-git::git+https://github.com/jackaudio/jack2
+ source = jack2-git::git+https://github.com/jackaudio/jack2#branch=master
md5sums = SKIP
pkgname = jack2-git
+ depends = db
+ depends = expat
+ depends = opus
+ depends = libasound.so
+ depends = libcelt0.so
+ depends = libdbus-1.so
+ depends = libreadline.so
+ depends = libsamplerate.so
+ depends = libsndfile.so
+ depends = libsystemd.so
diff --git a/.gitignore b/.gitignore
index 96b42f476264..0f16b4303778 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@ pkg/
src/
jack2-git/
jack2-git-*.pkg.tar.xz
+jack2-git-*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
index 5e917a4045cf..de8c9e4798b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,24 +6,26 @@
_name=jack2
pkgname=jack2-git
pkgdesc="C++ version of the JACK low-latency audio server for multi-processor machines"
-pkgver=1.9.13.r3.g3c340b81
+pkgver=1.9.16.r0.g5b78c2ef
pkgrel=1
epoch=1
arch=('x86_64')
url="http://jackaudio.org/"
license=('GPL2' 'LGPL2.1')
groups=('pro-audio')
-depends=('celt' 'opus' 'libsamplerate')
-makedepends=('git' 'libffado' 'portaudio' 'waf')
+depends=('db' 'expat' 'opus')
+makedepends=('alsa-lib' 'celt' 'dbus' 'git' 'libffado' 'libsamplerate'
+ 'libsndfile' 'readline' 'systemd-libs' 'waf')
optdepends=('a2jmidid: Expose legacy ALSA sequencer applications in JACK MIDI'
'libffado: Firewire support'
'portaudio: Portaudio support'
'python-dbus: For jack_control'
- 'realtime-privileges: Acquire realtime privileges')
+ 'realtime-privileges: Acquire realtime privileges'
+ 'zita-ajbridge: for using multiple ALSA devices')
provides=('jack' 'jack2' 'libjack.so' 'libjacknet.so' 'libjackserver.so')
conflicts=('jack' 'jack2')
replaces=('jack2-dbus-git')
-source=("${pkgname}::git+https://github.com/jackaudio/${_name}")
+source=("${pkgname}::git+https://github.com/jackaudio/${_name}#branch=master")
md5sums=('SKIP')
prepare() {
@@ -34,11 +36,9 @@ prepare() {
touch __init__.py
mkdir -vp tools
cp -v waflib/extras/xcode*.py tools
- mv -v autooptions/__init__.py tools/autooptions.py
rm -rv waflib
sed -e "s/load('xcode'/load('xcode', tooldir='tools'/g" \
-e "s/load('xcode6'/load('xcode6', tooldir='tools'/g" \
- -e "s/load('autooptions'/load('autooptions', tooldir='tools'/g" \
-i wscript
)
}
@@ -51,6 +51,7 @@ pkgver() {
build() {
cd "${pkgname}"
+ export PYTHONPATH="${PWD}:${PYTHONPATH}"
waf configure --prefix=/usr \
--htmldir="/usr/share/doc/${pkgbase}/" \
--systemd-unit \
@@ -60,7 +61,10 @@ build() {
}
package() {
+ depends+=('libasound.so' 'libcelt0.so' 'libdbus-1.so' 'libreadline.so'
+ 'libsamplerate.so' 'libsndfile.so' 'libsystemd.so')
cd "${pkgname}"
+ export PYTHONPATH="${PWD}:${PYTHONPATH}"
waf install --destdir="$pkgdir"
}