summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2020-06-22 22:12:49 +0200
committerChristopher Arndt2020-06-22 22:12:49 +0200
commit02371c96dfd5166c34b642838b5594c2bb057994 (patch)
tree82ca09367507e9b848615268fedd3c149530c1c0
parent4279886f67cbae6e93e3edded61cc0b7f086151c (diff)
downloadaur-02371c96dfd5166c34b642838b5594c2bb057994.tar.gz
Add patch to remove GConf use; fix dependencies and conflicts
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
-rw-r--r--jack_mixer-12-remove_gconf.patch25
-rw-r--r--jack_mixer-no-gconf-gui.patch16
4 files changed, 79 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 970f1d6101e6..00fc5ce36382 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,32 @@
pkgbase = jack_mixer-git
pkgdesc = A GTK based Jack audio mixer (GTK3 git version)
pkgver = 12.r285.5e45976
- pkgrel = 1
+ pkgrel = 2
url = https://rdio.space/jackmixer/
arch = x86_64
+ groups = pro-audio
license = GPL2
makedepends = git
- depends = libjack.so
+ makedepends = glib2
+ makedepends = jack
+ depends = gcc-libs
+ depends = python-cairo
depends = python-gobject
depends = hicolor-icon-theme
provides = jack_mixer
+ conflicts = jack_mixer
source = jack_mixer::git+https://github.com/jack-mixer/jack_mixer.git
+ source = jack_mixer-12-remove_gconf.patch
+ source = jack_mixer-no-gconf-gui.patch
sha256sums = SKIP
+ sha256sums = 87f41eb0e73e764af6cd9ce392c1b9a59376b120242178239dd8ad05218e258c
+ sha256sums = e4284bfc4b0e09a6bdfe3e5a6f8bc1c73f1468f45ef2a977a4d0d5e2324f1b92
pkgname = jack_mixer-git
+ depends = gcc-libs
+ depends = python-cairo
+ depends = python-gobject
+ depends = hicolor-icon-theme
+ depends = libglib-2.0.so
+ depends = libjack.so
diff --git a/PKGBUILD b/PKGBUILD
index 233011466ec5..1cab8fb0740e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,22 @@
_pkgname=jack_mixer
pkgname="${_pkgname}-git"
pkgver=12.r285.5e45976
-pkgrel=1
+pkgrel=2
pkgdesc="A GTK based Jack audio mixer (GTK3 git version)"
arch=('x86_64')
url="https://rdio.space/jackmixer/"
license=('GPL2')
-depends=('libjack.so' 'python-gobject' 'hicolor-icon-theme')
-makedepends=('git')
+groups=('pro-audio')
+depends=('gcc-libs' 'hicolor-icon-theme' 'python-cairo' 'python-gobject')
+makedepends=('git' 'glib2' 'jack')
provides=("${_pkgname}")
-conflictss=("${_pkgname}")
-source=("${_pkgname}::git+https://github.com/jack-mixer/jack_mixer.git")
-sha256sums=('SKIP')
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git+https://github.com/jack-mixer/jack_mixer.git"
+ 'jack_mixer-12-remove_gconf.patch'
+ 'jack_mixer-no-gconf-gui.patch')
+sha256sums=('SKIP'
+ '87f41eb0e73e764af6cd9ce392c1b9a59376b120242178239dd8ad05218e258c'
+ 'e4284bfc4b0e09a6bdfe3e5a6f8bc1c73f1468f45ef2a977a4d0d5e2324f1b92')
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -21,15 +26,22 @@ pkgver() {
echo "$ver.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+ # remove legacy gconf integration
+ # https://github.com/jack-mixer/jack_mixer/issues/2
+ patch -p1 -N -i "${srcdir}/jack_mixer-12-remove_gconf.patch" || :
+ patch -p1 -N -i "${srcdir}/jack_mixer-no-gconf-gui.patch" || :
+}
+
build() {
cd "${srcdir}/${_pkgname}"
- ./autogen.sh --prefix=/usr \
- --sysconfdir=/usr/share \
- --disable-schemas-install
+ ./autogen.sh --prefix=/usr
make
}
package() {
+ depends+=('libglib-2.0.so' 'libjack.so')
cd "${srcdir}/${_pkgname}"
make DESTDIR="${pkgdir}" install
# Install documentation
diff --git a/jack_mixer-12-remove_gconf.patch b/jack_mixer-12-remove_gconf.patch
new file mode 100644
index 000000000000..7c2a963dcecb
--- /dev/null
+++ b/jack_mixer-12-remove_gconf.patch
@@ -0,0 +1,25 @@
+diff -ruN a/Makefile.am b/Makefile.am
+--- a/Makefile.am 2020-06-22 14:51:45.000000000 +0200
++++ b/Makefile.am 2020-06-22 18:57:58.556361735 +0200
+@@ -59,21 +59,9 @@
+ test: _jack_mixer_c.so
+ @./test.py
+
+-schemadir = @GCONF_SCHEMA_FILE_DIR@
+-schema_DATA = jack_mixer.schemas
+-
+ install-exec-hook:
+ ln -vfs jack_mixer.py $(DESTDIR)$(bindir)/jack_mixer
+
+-if GCONF_SCHEMAS_INSTALL
+-install-data-hook:
+- GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(srcdir)/$(schema_DATA)
+-
+-uninstall-hook:
+- GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-uninstall-rule $(srcdir)/$(schema_DATA)
+- rm -vf $(DESTDIR)$(bindir)/jack_mixer
+-endif
+-
+ pacoinstall:
+ test `whoami` == root # test for root
+ -paco -rvB jack_mixer
diff --git a/jack_mixer-no-gconf-gui.patch b/jack_mixer-no-gconf-gui.patch
new file mode 100644
index 000000000000..e168a279c564
--- /dev/null
+++ b/jack_mixer-no-gconf-gui.patch
@@ -0,0 +1,16 @@
+diff --git a/gui.py b/gui.py
+index 9b555e1..8d9c3b6 100644
+--- a/gui.py
++++ b/gui.py
+@@ -16,10 +16,10 @@
+ # Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA.
+
+ import gi
+-gi.require_version('GConf', '2.0')
+ from gi.repository import GObject
+
+ try:
++ gi.require_version('GConf', '2.0')
+ from gi.repository import GConf
+ except:
+ print("Cannot load Python bindings for GConf, your preferences will not be preserved across jack_mixer invocations")