summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Wolff2016-09-25 10:15:52 +0200
committerJulian Wolff2016-09-25 10:15:52 +0200
commitf6f1886218b783f646bf0beb3e9b88368305dd06 (patch)
treeef73bf5e7f8b80cc71f8ef815e6f97fbc0746b1d
downloadaur-f6f1886218b783f646bf0beb3e9b88368305dd06.tar.gz
initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore3
-rw-r--r--.install35
-rw-r--r--PKGBUILD46
4 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..972df1923039
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Sun Sep 25 08:13:57 UTC 2016
+pkgbase = jackman-git
+ pkgdesc = Collection of scripts that help managing multiple audio interfaces with Jack
+ pkgver = 0.1
+ pkgrel = 1
+ install = .install
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = jack2
+ depends = alsa-utils
+ depends = systemd
+ depends = coreutils
+ optdepends = zenity: system notifications
+ optdepends = kdebase-kdialog: system notifications
+ provides = jackman
+ conflicts = jackman
+ source = jackman::git+https://github.com/progwolff/jackman.git
+ md5sums = SKIP
+
+pkgname = jackman-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..85e77c6e4f32
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src*
+pkg*
+jackman*
diff --git a/.install b/.install
new file mode 100644
index 000000000000..ff9f34f91af6
--- /dev/null
+++ b/.install
@@ -0,0 +1,35 @@
+# This is a default template for a post-install scriptlet.
+# Uncomment only required functions and remove any functions
+# you don't need (and this header).
+
+## arg 1: the new package version
+#pre_install() {
+ # do something here
+#}
+
+## arg 1: the new package version
+post_install() {
+ systemctl enable jackman_plug@" ".service
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+#pre_upgrade() {
+ # do something here
+#}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ systemctl enable jackman_plug@" ".service
+}
+
+## arg 1: the old package version
+#pre_remove() {
+ # do something here
+#}
+
+## arg 1: the old package version
+#post_remove() {
+ # do something here
+#}
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e1dfc7f7b70
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Julian Wolff <wolff at julianwolff dot de>
+pkgname=jackman-git
+pkgver=r44.b8fa19b
+pkgrel=1
+pkgdesc='Collection of scripts that help managing multiple audio interfaces with Jack'
+arch=('any')
+url=''
+license=('GPL')
+conflicts=(jackman)
+provides=(jackman)
+depends=('jack2' 'alsa-utils' 'systemd' 'coreutils')
+makedepends=('git')
+optdepends=('zenity: system notifications'
+ 'kdebase-kdialog: system notifications')
+source=('jackman::git+https://github.com/progwolff/jackman.git')
+md5sums=('SKIP')
+
+_gitroot="https://github.com/progwolff/jackman.git"
+_gitname=jackman
+
+pkgver() {
+ cd "$_gitname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+install=.install
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/etc/udev/rules.d"
+ mkdir -p "$pkgdir/usr/lib/systemd/system/"
+ mkdir -p "$pkgdir/etc/xdg/autostart/"
+ cp ./${_gitname}/50-jackman.rules "$pkgdir/etc/udev/rules.d/"
+ cp ./${_gitname}/jackman "$pkgdir/usr/bin/"
+ cp ./${_gitname}/jackman_udev* "$pkgdir/usr/bin/"
+ cp ./${_gitname}/alsa* "$pkgdir/usr/bin/"
+ cp ./${_gitname}/*.service "$pkgdir/usr/lib/systemd/system/"
+ for d in `cd ./${_gitname}/po; ls -1 *.po 2>/dev/null`; do
+ mkdir -p "$pkgdir/usr/share/locale/${d%.po}/LC_MESSAGES"
+ msgfmt -o "$pkgdir/usr/share/locale/${d%.po}/LC_MESSAGES/jackman.mo" ./${_gitname}/po/${d}
+ done
+}
+