summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredtide2019-11-08 18:25:09 +0100
committerredtide2019-11-08 18:25:09 +0100
commit2e84b763be37bc883ab9ec11d31cfd396c0517ca (patch)
tree534e338032bdcbddd6d4710a01c69f670da41d60
parent915e57bfbde4db02a43a0bb662bb73f9dfdb89ea (diff)
downloadaur-2e84b763be37bc883ab9ec11d31cfd396c0517ca.tar.gz
Use un-annotated tags for versions.
-rw-r--r--PKGBUILD5
1 files changed, 1 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 88e4268fdfd8..859ef5c20357 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,10 +14,7 @@ source=("${pkgname}"::"git+https://github.com/azdrums/${pkgname}.git")
md5sums=('SKIP')
pkgver() {
cd "$pkgname"
- ( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
cd "${srcdir}/${pkgname}"