summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDevin J. Pohly2019-11-28 12:09:44 -0600
committerDevin J. Pohly2019-11-28 12:09:44 -0600
commit6e11cb818e9bb00c1addb7946783e2af36348232 (patch)
treec877f32225a149bc8f8f2cc07c18d7c309c11681
downloadaur-6e11cb818e9bb00c1addb7946783e2af36348232.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b48b07a91ad9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = jackstrobe-git
+ pkgdesc = Simple strobe tuner using JACK and Qt 5
+ pkgver = r8.87dc213
+ pkgrel = 1
+ url = https://github.com/jessecrossen/jackstrobe
+ arch = x86_64
+ license = Unlicense
+ makedepends = git
+ depends = jack
+ depends = qt5-base
+ provides = jackstrobe
+ conflicts = jackstrobe
+ source = git+https://github.com/jessecrossen/jackstrobe
+ md5sums = SKIP
+
+pkgname = jackstrobe-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..622049ff0a04
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Devin J. Pohly <djpohly+arch@gmail.com>
+pkgname=jackstrobe-git
+pkgver=r8.87dc213
+pkgrel=1
+pkgdesc="Simple strobe tuner using JACK and Qt 5"
+arch=('x86_64')
+url="https://github.com/jessecrossen/jackstrobe"
+license=('Unlicense')
+depends=('jack' 'qt5-base')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/jessecrossen/jackstrobe')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}/project"
+ qmake-qt5 PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}/project"
+ install -D jackstrobe "$pkgdir/usr/bin/jackstrobe"
+}