summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorg Schlisio2016-06-09 21:17:15 +0200
committerGeorg Schlisio2016-06-09 21:17:15 +0200
commit1440713ba8b5f8301ac1dc4a06dc8af578399a0d (patch)
tree70bc9ca782699bc0cac1050446d77d90276f56a5
parentc8f9d9c4539dfc31ef5eb69040bb552313f01889 (diff)
downloadaur-1440713ba8b5f8301ac1dc4a06dc8af578399a0d.tar.gz
change to java 8, encourage usage of new plugin system, change PKGBUILD to patch instead of sed
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD39
-rw-r--r--jameica-start-script.patch17
-rw-r--r--jameica.install13
-rw-r--r--jameicaserver-start-script.patch15
5 files changed, 82 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 22ed9cba50a2..e3d03b32f91a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,27 @@
pkgbase = jameica
pkgdesc = free runtime environment for java applications
pkgver = 2.6.4
- pkgrel = 2
+ pkgrel = 3
url = https://www.willuhn.de/products/jameica/
+ install = jameica.install
arch = i686
arch = x86_64
license = GPL2
makedepends = unzip
- depends = java-runtime>=1.5
+ depends = java-runtime>=8
depends = java-environment
depends = swt
- source = jameica-2.6.4::https://www.willuhn.de/projects/jameica/releases/2.6/jameica/jameica-linux64.zip
- sha1sums = 7d3d6104b75d41b0baebdf7cbbdf3fca64012e13
+ optdepends = java-jce_ustrength: Required for mashup plugin used as new scripting platform for non-HBCI accounts (credit cards etc)
+ source = jameica-start-script.patch
+ source = jameicaserver-start-script.patch
+ source = jameica.install
+ sha1sums = a6a696d465929f373d6c0d469463aa28b0f4c11f
+ sha1sums = 05ca5cf474523db10789eea9cb483cdf12d8549b
+ sha1sums = 2076491611ac0bc99863fa3e5b0909ff961b7999
+ source_i686 = jameica-2.6.4.zip::https://www.willuhn.de/projects/jameica/releases/2.6/jameica/jameica-linux.zip
+ sha1sums_i686 = f659abd95ac062846f14c067fea5061bd5c4cd54
+ source_x86_64 = jameica-2.6.4.zip::https://www.willuhn.de/projects/jameica/releases/2.6/jameica/jameica-linux64.zip
+ sha1sums_x86_64 = 7d3d6104b75d41b0baebdf7cbbdf3fca64012e13
pkgname = jameica
diff --git a/PKGBUILD b/PKGBUILD
index 70dbd0b96b52..52dfe11dab0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,37 @@
pkgname=jameica
pkgver=2.6.4
_pkgver=2.6
-pkgrel=2
+pkgrel=3
pkgdesc="free runtime environment for java applications"
arch=('i686' 'x86_64')
url="https://www.willuhn.de/products/jameica/"
license=("GPL2")
-depends=('java-runtime>=1.5' 'java-environment' 'swt')
+depends=('java-runtime>=8' 'java-environment' 'swt')
+optdepends=('java-jce_ustrength: Required for mashup plugin used as new scripting platform for non-HBCI accounts (credit cards etc)')
makedepends=('unzip')
+install="jameica.install"
# See https://willuhn.de/products/jameica/download.php for checksums
-if [ "$CARCH" = "i686" ]; then
- source=("${pkgname}-${pkgver}::https://www.willuhn.de/projects/jameica/releases/$_pkgver/jameica/$pkgname-linux.zip")
- sha1sums=('f659abd95ac062846f14c067fea5061bd5c4cd54')
-elif [ "$CARCH" = "x86_64" ]; then
- source=("${pkgname}-${pkgver}::https://www.willuhn.de/projects/jameica/releases/$_pkgver/jameica/$pkgname-linux64.zip")
- sha1sums=('7d3d6104b75d41b0baebdf7cbbdf3fca64012e13')
-fi
+source_i686=("${pkgname}-${pkgver}.zip::https://www.willuhn.de/projects/jameica/releases/$_pkgver/jameica/$pkgname-linux.zip")
+sha1sums_i686=('f659abd95ac062846f14c067fea5061bd5c4cd54')
+source_x86_64=("${pkgname}-${pkgver}.zip::https://www.willuhn.de/projects/jameica/releases/$_pkgver/jameica/$pkgname-linux64.zip")
+sha1sums_x86_64=('7d3d6104b75d41b0baebdf7cbbdf3fca64012e13')
+source=("jameica-start-script.patch"
+ "jameicaserver-start-script.patch"
+ "jameica.install")
+sha1sums=('a6a696d465929f373d6c0d469463aa28b0f4c11f'
+ '05ca5cf474523db10789eea9cb483cdf12d8549b'
+ '2076491611ac0bc99863fa3e5b0909ff961b7999')
prepare() {
- cd "$srcdir/jameica"
- sed -i '6c cd /opt/jameica' jameica.sh jameicaserver.sh
- sed -i '10 s/lib\/swt\/linux/\/usr\/lib/' jameica.sh jameicaserver.sh
- sed -i '10 s/$@/& \&> \/dev\/null \&/' jameica.sh jameicaserver.sh
- sed -i '/^dir/d' jameica.sh jameicaserver.sh
- sed -i '/^link/d' jameica.sh jameicaserver.sh
- sed -i '/^cd "$dir"/d' jameica.sh jameicaserver.sh
+ patch jameica/jameica.sh jameica-start-script.patch
+ patch jameica/jameicaserver.sh jameicaserver-start-script.patch
+ #cd "$srcdir/jameica"
+ #sed -i '6c cd /opt/jameica' jameica.sh jameicaserver.sh
+ #sed -i '10 s/lib\/swt\/linux/\/usr\/lib/' jameica.sh jameicaserver.sh
+ #sed -i '10 s/$@/& \&> \/dev\/null \&/' jameica.sh jameicaserver.sh
+ #sed -i '/^dir/d' jameica.sh jameicaserver.sh
+ #sed -i '/^link/d' jameica.sh jameicaserver.sh
+ #sed -i '/^cd "$dir"/d' jameica.sh jameicaserver.sh
}
package() {
diff --git a/jameica-start-script.patch b/jameica-start-script.patch
new file mode 100644
index 000000000000..820f0f1a3b5e
--- /dev/null
+++ b/jameica-start-script.patch
@@ -0,0 +1,17 @@
+6c6
+< #_JCONSOLE="-Dcom.sun.management.jmxremote"
+---
+> cd /opt/jameica
+11,13d10
+< link=$(readlink -f "$0")
+< dir=$(dirname "$link")
+< cd "$dir"
+21c18,23
+< LIBOVERLAY_SCROLLBAR=0 GDK_NATIVE_WINDOWS=1 SWT_GTK3=0 exec java -Djava.net.preferIPv4Stack=true -Xmx512m $_JCONSOLE -jar jameica-linux${archsuffix}.jar $@
+---
+> # enable to use the default version of java provided by java-runtime-common
+> #_java=/usr/bin/java
+> # use java 8 for mashup plugin
+> _java=/usr/lib/jvm/java-8-openjdk/jre/bin/java
+>
+> LIBOVERLAY_SCROLLBAR=0 GDK_NATIVE_WINDOWS=1 SWT_GTK3=0 exec $_java -Djava.net.preferIPv4Stack=true -Xmx512m $_JCONSOLE -jar jameica-linux${archsuffix}.jar $@
diff --git a/jameica.install b/jameica.install
new file mode 100644
index 000000000000..170a798a0630
--- /dev/null
+++ b/jameica.install
@@ -0,0 +1,13 @@
+post_upgrade(){
+cat << \here
+The scripting infrastructure for non-HBCI accounts was thoroughly modernized.
+While the old scripts continue to work they receive no further mainenance.
+It is thus adviced to change to the new Release 3, following advice at [0].
+To use the new MashUp plugin java-environment 8 and java-jce_ustrength is required.
+The jameica starter has been changed to start java 8. If you wish to continue
+using java 7, change the appropriate lines in /usr/bin/jameica and /usr/bin/jameicaserver.
+More information here [0].
+[0] http://scripting-forum.derrichter.de/viewtopic.php?f=34&t=192
+[] http://hibiscus-scripting.derrichter.de/
+here
+}
diff --git a/jameicaserver-start-script.patch b/jameicaserver-start-script.patch
new file mode 100644
index 000000000000..416cec6ad4ec
--- /dev/null
+++ b/jameicaserver-start-script.patch
@@ -0,0 +1,15 @@
+6,8c6
+< link=$(readlink -f "$0")
+< dir=$(dirname "$link")
+< cd "$dir"
+---
+> cd /opt/jameica
+14c12,17
+< java -Djava.net.preferIPv4Stack=true -Xmx256m $_JCONSOLE -jar jameica-linux.jar -d $@
+---
+> # enable to use the default version of java provided by java-runtime-common
+> #_java=/usr/bin/java
+> # use java 8 for mashup plugin
+> _java=/usr/lib/jvm/java-8-openjdk/jre/bin/java
+>
+> $_java -Djava.net.preferIPv4Stack=true -Xmx256m $_JCONSOLE -jar jameica-linux.jar -d $@