summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-09-12 11:16:34 -0600
committerMark Wagie2021-09-12 11:16:34 -0600
commit83b8cdb9a97841eaa42d507b34bcfc55bf8b7330 (patch)
treeb263d10c04bd7aba548b4cf63e92ae44f08173a4
downloadaur-83b8cdb9a97841eaa42d507b34bcfc55bf8b7330.tar.gz
initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD46
-rw-r--r--jamesdsp.desktop11
4 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad143156be69
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = jamesdsp
+ pkgdesc = An audio effect processor for PipeWire clients
+ pkgver = 2.0
+ pkgrel = 1
+ url = https://github.com/Audio4Linux/JDSP4Linux
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = glibmm
+ depends = pipewire
+ depends = qt5-svg
+ conflicts = jdsp4linux
+ conflicts = jdsp4linux-gui
+ conflicts = gst-plugin-jamesdsp
+ replaces = jdsp4linux
+ replaces = jdsp4linux-gui
+ replaces = gst-plugin-jamesdsp
+ source = git+https://github.com/Audio4Linux/JDSP4Linux.git#tag=2.0
+ source = git+https://github.com/ThePBone/EELEditor.git
+ source = jamesdsp.desktop
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = c6496e6981471aa3f8d1593673991e422d243ff3efe595b3230de713588599c3
+
+pkgname = jamesdsp
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4b4ed6a50960
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!jamesdsp.desktop
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f570577bf9bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=jamesdsp
+pkgver=2.0
+pkgrel=1
+pkgdesc="An audio effect processor for PipeWire clients"
+arch=('x86_64')
+url="https://github.com/Audio4Linux/JDSP4Linux"
+license=('GPL3')
+depends=('glibmm' 'pipewire' 'qt5-svg')
+makedepends=('git')
+conflicts=('jdsp4linux' 'jdsp4linux-gui' 'gst-plugin-jamesdsp')
+replaces=('jdsp4linux' 'jdsp4linux-gui' 'gst-plugin-jamesdsp')
+source=("git+https://github.com/Audio4Linux/JDSP4Linux.git#tag=$pkgver"
+ 'git+https://github.com/ThePBone/EELEditor.git'
+ 'jamesdsp.desktop')
+sha256sums=('SKIP'
+ 'SKIP'
+ 'c6496e6981471aa3f8d1593673991e422d243ff3efe595b3230de713588599c3')
+
+prepare() {
+ cd "$srcdir/JDSP4Linux"
+ git submodule init src/subprojects/EELEditor
+ git config submodule.EELEditor.url "$srcdir/EELEditor"
+ git submodule update
+
+ mkdir -p build
+}
+
+build() {
+ cd "$srcdir/JDSP4Linux"
+
+ pushd build
+ qmake ..
+ make
+ popd
+}
+
+package() {
+ cd "$srcdir/JDSP4Linux"
+ install -Dm755 build/src/jamesdsp -t "$pkgdir/usr/bin"
+ install -Dm644 resources/icons/icon.png \
+ "$pkgdir/usr/share/pixmaps/jamesdsp.png"
+ install -Dm644 resources/icons/icon.svg \
+ "$pkgdir/usr/share/icons/hicolor/scalable/apps/jamesdsp.svg"
+ install -Dm644 "$srcdir/jamesdsp.desktop" -t "$pkgdir/usr/share/applications"
+}
diff --git a/jamesdsp.desktop b/jamesdsp.desktop
new file mode 100644
index 000000000000..f4550767842a
--- /dev/null
+++ b/jamesdsp.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=JamesDSP
+GenericName=Audio effect processor
+Comment=JamesDSP for Linux
+Keywords=equalizer;audio;effect
+Categories=AudioVideo;Audio
+Exec=jamesdsp
+Icon=jamesdsp
+StartupNotify=false
+Terminal=false
+Type=Application